Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just put Jolicloud on my wife's netbook, and while most of the features work fine, her SD card is kind of hit or miss. When it was first installed, I think the default fstab had it being mounted as /media/cdrom0 (?) but it wasn't 100% -- sometimes, inserting the card mounted it, and other times it didn't.

I futzed with the fstab a bit (switched from dev node to UUID, etc) , but the behavior remains the same. When I do succeed in mounting it, most times I get a "does not match fstab" error when I try to unmount it -- have to unmount as root to work around it. I set up scripts in her home directory for mount / unmount, and they work a treat (bit of a pain to have to put in her password to unmount, but...). It would be nice if it "just worked", though.

Does anybody have a solid "next step" for troubleshooting this? I'm getting USB detection messages in /var/log/messages on removal and insert, but for some reason the mount just isn't firing off.

share|improve this question
    
This sounds like a Jolicloud-specific issue. I have no idea what this OS is based on. I'd expect a recent Linux distribution to use udev for this kind of work, and in that case it's very surprising if you get a "does not match fstab" error. –  ℝaphink Dec 25 '09 at 23:00
    
Um, to be fair, I think I was getting a different error out-of-the-box (that is, before I edited fstab). Maybe I can revert my fstab and see if behavior improves, but I'm not expecting much. –  James B Dec 25 '09 at 23:50
    
what mountpoint does your fstab entry list? where does the device get mounted? –  quack quixote Dec 26 '09 at 1:29
    
i've read somewhere else that jolicloud is ubuntu-based, but i really don't know much about it specifically. –  quack quixote Dec 26 '09 at 1:50

1 Answer 1

up vote 0 down vote accepted

I wonder if your troubles are the card reader in general, or if they only follow certain SD cards (but work with others). This is probably how I'd go about troubleshooting:

  • Have you tried other cards?
  • How are the cards formatted?
  • Are they all the same manufacturer?

In particular, I note your mention of a mismatch between your fstab entry's mountpoint and where the system actually mounts the device; this sounds like Gnome-VFS or another automounter mounted the device at a volume-label-based mountpoint.

Honestly, I don't think your SD card reader belongs in /etc/fstab. It's a bit like the CD/DVD device: it could go there, but you'd need to use the device entry (which might change over reboots), and the GNOME/KDE automounters probably do a better job handling it anyway. UUIDs are worthless here: you'd need one entry for each SD card you're using, or you'd need to take pains to ensure that all your SD cards are marked with the same UUID. Volume labels are the same way. So if you have an fstab entry at all, it should be the device entry and a generic mountpoint, like /media/sdcard0 or some such.

Ideally you'd want to figure out why the desktop environment's automounter isn't functioning properly. Does it work with a USB stick or other external drive? The proper function (on GNOME, KDE should be similar) should be:

  • insert new device,
  • system recognizes device,
  • system mounts device (usually at /media/<volume_label>)
  • system creates new icon on desktop for device

The actual system chain of events is more like this:

  1. uDev (kernel hotplug subsystem) registers new device or "media change" notifier
  2. uDev notifies DBus/HAL about the hardware change
  3. DBus/HAL passes this along to registered listeners (eg Gnome-VFS)
  4. if a user is logged into GNOME, Gnome-VFS (running as the user) is listening, and should handle
    1. mountpoint creation (based on the volume label of the new media)
    2. device mount
    3. icon creation

I've written up about using uDev and HALevt as automounters (similar to Gnome-VFS) in another question; there's lots of good info there about the underlying system processes, so those may be of use to you.

Given the above process, can you identify a particular area where the trouble is being introduced?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.