Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I used to be able to see and manage my iPod with different softwares: Amarok, Rhythmbox, GTKPod. The device is a nano 1st generation 4gb.

Currently it mounts regularly and can be accessed from the file system, but I get this in dmesg:

[ 1547.617891] scsi 11:0:0:0: Direct-Access     Apple    iPod             1.62 PQ: 0 ANSI: 0
[ 1547.619103] sd 11:0:0:0: Attached scsi generic sg2 type 0
[ 1547.620478] sd 11:0:0:0: [sdb] Adjusting the sector count from its reported value: 7999488
[ 1547.620494] sd 11:0:0:0: [sdb] 7999487 512-byte hardware sectors: (4.09 GB/3.81 GiB)
[ 1547.621718] sd 11:0:0:0: [sdb] Write Protect is off
[ 1547.621726] sd 11:0:0:0: [sdb] Mode Sense: 68 00 00 08
[ 1547.621732] sd 11:0:0:0: [sdb] Assuming drive cache: write through
[ 1547.623591] sd 11:0:0:0: [sdb] Adjusting the sector count from its reported value: 7999488
[ 1547.624993] sd 11:0:0:0: [sdb] Assuming drive cache: write through
[ 1547.625003]  sdb: sdb1 sdb2
[ 1547.629686] sd 11:0:0:0: [sdb] Attached SCSI removable disk
[ 1548.084026] FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
[ 1548.369502] FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
[ 1548.504358] FAT: invalid media value (0x2f)
[ 1548.504363] VFS: Can't find a valid FAT filesystem on dev sdb1.
[ 1548.945173] FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
[ 1548.945179] FAT: invalid media value (0x2f)
[ 1548.945182] VFS: Can't find a valid FAT filesystem on dev sdb1.
[ 1610.092886] usb 2-6: USB disconnect, address 9

The only application that can access it (partially) is Rhythmbox. I say partially because I can transfer files to the iPod but can't remove or modify them. Also one transfer didn't finish and only 9 out of 16 songs were delivered to the device. All other softwares I tried (GTKPod, Amarok, Songbird) don't even detect it.

What can I do to troubleshoot this?


# fdisk -l /dev/sdb

Disk /dev/sdb: 4095 MB, 4095737344 bytes
241 heads, 62 sectors/track, 535 cylinders
Units = cylinders of 14942 * 512 = 7650304 bytes
Disk identifier: 0x20202020

Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1          11       80293+   0  Empty
Partition 1 has different physical/logical beginnings (non-Linux?):
    phys=(0, 1, 1) logical=(0, 1, 2)
Partition 1 has different physical/logical endings:
    phys=(9, 254, 63) logical=(10, 181, 8)
Partition 1 does not end on cylinder boundary.
/dev/sdb2              11         536     3919415+   b  W95 FAT32
Partition 2 has different physical/logical beginnings (non-Linux?):
    phys=(10, 0, 7) logical=(10, 181, 15)
Partition 2 has different physical/logical endings:
    phys=(497, 240, 62) logical=(535, 88, 61)


The "before" state is hard to tell, it was a lot of updates ago. Haven't been using my iPod for a while so I can't say when exactly it stopped working. I'm sure Amarok was still at version 1.X but can't remember when it was. My current system is debian testing fully updated.

NOTE: just noticed that if I mount the device manually instead of letting nautilus automount it, I can see it again on GTKPod but still not on Banshee AND it's vanished from Rhythmbox...

share|improve this question
I'm afraid I've got no advice but wanted to share my experience trying to use my ipod nano (3rd g i think?) with linux. If I remember right, it mounted automatically (ubuntu 9.10 btw), all songs played perfectly, and I was able to transfer files in both directions. When i disconnected the ipod though and tried to listen to files - my ipod was empty! even though both ubuntu and windows7 were able to see the music on it. apple wouldnt support linux and told me to restore the ipod. I did after backing up the files, and i haven't solved the problem since. – user10580 Dec 26 '09 at 20:34
You say you used to be able to manage your iPod with various software - what have you changed? Which are you running - stable/testing/unstable? Update your question with the "before" state. – camh Dec 30 '09 at 1:38

You could try Floola.

It's got some database repair functions, which have helped me out in the past.

share|improve this answer

The messages you're seeing there for /dev/sdb1 are entirely normal, since there isn't a FAT file system on it.

Can you post the output of fdisk -l when you plug it into your PC?

And if there is more dmesg output which mentions /dev/sdb2, post that too.

Edit: I've just noticed that you said in your original question that it actually mounts normally - in which case the output you're getting in dmesg is entirely irrelevant ;)

The next thing to do would be to run a fsck on the file system, since the problem you're describing could be attributed to a damaged filesystem too. To do that, you're going to want to plug the thing in, and manually unmount it:

umount /dev/sdb2

and then

fsck -av /dev/sdb2

Once that's completed, disconnect and then reconnect it, and then cross your fingers :)

share|improve this answer
Added output of fdisk -l /dev/sdb. Nothing else relevant in dmesg output. – Matteo Riva Dec 26 '09 at 20:24

Keeping things simple - if you don't have any files that are uniquely on the iPod (i.e. everything exists on another computer somewhere), connect it to a Windows or Mac computer and use iTunes to 'Restore Factory Settings'.

This button to do this is available from the iPod management page behind the music/movies or whatever else you have on your iPod.

For more info check:

share|improve this answer

I use VirtualBox on Linux to run iTunes to upload music to my phone. This method is slow; but it works. So if you have the MS Windows install media, install a virtual machine with Windows and iTunes.

VirtualBox (, Oracle

share|improve this answer

you could try and open it with Itunes on a windows computer, i found that sometimes the itunes DB gets messed up

share|improve this answer

Have you tried accessing the iPod normally using a Windows or Mac computer? It's a bit weird how two of the programmes will "partially" connect to it and the others won't. It may be a case that the iPod is on it's last legs and the memory inside the device is failing.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .