Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just signed up for service with Time Warner cable in Dallas, TX. I am supposed to get 7Mbps down w/ bursting to 10Mbps. If I connect the cable modem directly to my PC, I get the advertised speed. If I go through my router I rarely get above 2Mbps. I know its not my router because I went and bought two new routers, both different brands and the same issue occurs. I've also tried both of my laptops so I know its not the computer either. At this point I'm almost positive its their service. No router = fast, w/ router = slow. Has anyone had this issue?

Currently I use a Linksys WRT54G w/ DD-WRT as my router with Windows 7. I've been using it for years without issue. If know one has any ideas I'll have to call CS and pretend I'm not using a router since their only fix is for me not to use a router which I find unacceptable.

share|improve this question
1  
I tried flashing to the official firmware, no dice. I did fix it though. For some reason cloning my PC's MAC address to the router fixed the speed issue. –  Juice Dec 27 '09 at 2:38
    
@Luminose, that's an important comment. Others may have this same problem so post it in an answer, accept it, and I'll vote you up. –  hyperslug Dec 27 '09 at 3:13

3 Answers 3

up vote 4 down vote accepted

Cloning my PC's MAC address instead of using the router MAC address fixed my speed issue.

share|improve this answer
    
What's interesting/tricky about this is that your ISP permitted a slow connection to a foreign MAC address rather than completely blocking it. –  hyperslug Dec 27 '09 at 12:57
    
What really makes me angry is that I've been on the phone numerous times with tech support and the only advice they can give is "reboot your router and modem". –  Juice Dec 27 '09 at 14:00

Some cable modems either require, or at least behave much better if you disable STP (DD-WRT Web Interface -> Setup Tab -> Basic Setup -> WAN Setup section). Also, I have seen the QoS settings wreak havoc on cable connections, as their "bursty" nature really doesn't play well. Disable any QoS on the router as well. Lastly, I find using dnsmasq on the router and having your computer use the private address (usually 192.168.1.1) as both gateway and DNS works best.

More information: http://www.dd-wrt.com/wiki/index.php/STP

share|improve this answer

If you're using DD-WRT on a router, you should look into flashing back to the default firmware of the router. It must be a setting within the router QoS.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.