Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't seem to install Windows 7 onto my second hard drive. I get this error:

Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk. Ensure that the disk's controller is enabled in the computer's BIOS menu.

Reformatting does nothing, my BIOS is set to boot from the hard drive first and still nothing. Any ideas?

share|improve this question

What version of Windows 7 are you using?

I see you have an EFI based system - Windows has limited support for EFI based systems, and I think it is only available in the x64/64-bit versions.

Also, you may want to read - Microsoft KB Article 925481 - Error message when you try to install Windows Vista on a computer that has uninitialized hard disks: "This computer's hardware may not support booting to this disk".

The KB is for Windows Vista, but should also apply to Windows 7.


This problem occurs because Windows Vista cannot distinguish between ambiguous hard disks.

In versions of Microsoft Windows Setup that are earlier than Windows Vista Setup, hard disks are marked with distinct values to distinguish them. However, this method of distinguishing hard disks is no longer supported because of the potential for data corruption on hard disks.


To resolve this problem, follow these steps:

  1. Create one or more partitions on all the hard disks that are not initialized.
  2. Restart the computer.
  3. Install Windows Vista.
share|improve this answer

you have to disable the SATA controller. i am sure

share|improve this answer

Fixed the problem, I unplugged my second HDD and it installed. I have no idea what the problem is, but this seems to work for installing, let's hope it boots.

share|improve this answer

delete the partition and recreate a new partition again with default NTFS setting and you should be good to go

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.