Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

just a slightly irritating problem:

I have two wifi networks in my home, and both have their WPA keys stored in the keychain. However if I am connected to one, but need to change to the other in mid-session, it asks me for the WPA key. Irritating because keys are quite long and cumbersome.

It doesn't do this at login time: always selects the last network I was using (or tried to use), so the keychain clearly knows the keys.

How can I get this behaviour also when I change networks in mid-session?

share|improve this question
add comment

3 Answers 3

up vote 2 down vote accepted

Prompting for an administrator password is a preference (but I guess that's not what you see when being asked for the WPA key?):

  • Go to System Preferences, Network
  • Select your AirPort network
  • Click button Advanced
  • See the option "Require administrator password to: Change networks"

Advanced AirPort preferences

As you commented that you already have that option disabled, maybe OS X has forgotten the password for Keychain Access? Check the following then:

  • Go to Utilities, Keychain Access
  • Open its preferences, pane First Aid
  • Consider enabling "Keep login keychain unlocked"?

Keychain Access preferences

(As an aside: see MarcoPolo to switch automatically!)

share|improve this answer
    
Actually that option was already unchecked, Arjan. –  Thomas Browne Dec 27 '09 at 12:02
    
It might be prompting for Keychain access then? –  Arjan Dec 27 '09 at 12:08
    
Thanks for your help,Arjan. Unfortunately my panel looks exactly like yours!! I'll play around with this and if I fix it I will post. –  Thomas Browne Dec 27 '09 at 14:02
add comment

I had the same problem problem -- network A -- to which I was able to connect anytime without entering password and B that was asking for password all the time. The only solution was to turn the airport off and then back on.

The answer was in the Keychain Access. I realized that A has 2 keychain records, in keychain login and system while B only in system.

I had some problems creating login keychain as it was disappearing again but in the end I have both of them even on the B network and all works as expected. The login keychain should allow access to AirPort and SystemUIServer.

share|improve this answer
add comment

I'm not sure, but it might be the AirPort admin setting:

  1. Go to the "Network" panel in the System Preferences App.
  2. Select AirPort on the left.
  3. Click on the (Advanced...) button
  4. Disable "Require Administrator Password to control AirPort˜
share|improve this answer
    
looks like my panels are different from those on Arjan's answer - I'm running Mac OS X 10.5.8 –  villares Dec 28 '09 at 15:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.