Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Have just upgraded from Vista to Windows 7 Home Premium (32 bit). On Vista Firefox worked great. I am using 3.5.6 version. 2GB RAM.

In Windows 7 however, whenever I click on a link, field or tab within the browser or various other places within Firefox 'Not Responding' flashes on the title bar.

Most of the time I have to click two or three times to get any link or whatever to work which is very annoying. Any ideas? I've seen other people have Not Responding messages a lot with various apps.

Have tried uninstall/reinstall including cleaning out installation directory. Have tried removing all addons as well. Still get the 'Not Responding' message occasionally flashing in the top right of the window title bar.

Have had to start using Chrome Plus as Firefox was driving me mad. I guess it's something else on my computer then and a mass uninstall/reinstall day beckons to try and isolate the issue.

share|improve this question

5 Answers 5

up vote 2 down vote accepted


To fix the screen flashing issue, follow steps below.

Run Registry Editor, and then delete the following registry keys:

  • HKEY_USERS.DEFAULT\Control Panel\Desktop\HungAppTimeOut
  • HKEY_USERS.DEFAULT\Control Panel\Desktop\WaitToKillAppTimeOut
  • HKEY_CURRENT_USER\Control Panel\Desktop\HungAppTimeOut
  • HKEY_CURRENT_USER\Control Panel\Desktop\WaitToKillAppTimeOut
  • HKEY_CURRENT_USER\Control Panel\Desktop\WaitToKillServiceTimeOut

Restart the computer after deletion, and the screen flashing issue on Windows 7 should be fixed.

share|improve this answer
Thanks for the reply that's done the trick. All is stable now. It would seem that unlike in Vista running anything more than one application for anti virus and anti spyware creates problems. MS Security Essentials running on its own seems to solve the problems i had –  Paul Feb 20 '10 at 8:14

Source: Fix Issue of Mozilla® Firefox not Responding to Clicks

Force end and restart program:

The issues with Mozilla Firefox browser might be due to minor errors or glitches in the application. The users who are having not responding issues with Mozilla Firefox browsers are advised to open the system Task Manager program and force end the application for restarting it. Restarting the program and starting a new session will help fix issues with it under minimal complications.

Remove incompatible add-ons:

The different third party add-ons installed in Mozilla Firefox browser in the interest of maximizing functionality can act differently and cause issues with the working of the program. Disable or remove incompatible add-ons and extensions from the browser and restart it for the changes to take effect.

Repair system registry:

The registry errors and threat infections in a computer can also cause the not responding issues with Mozilla Firefox browser. Do a complete system threat and registry scan so as to detect and fix valid issues. Doing so and restarting the system can help solve issues with the browser.

share|improve this answer

The problem must be with Flash. Follow these three simple steps:

  1. Run regedit.exe

  2. Delete the following keys:

    HKEY_USERS\.DEFAULT\Control Panel\Desktop\HungAppTimeOut
    HKEY_USERS\.DEFAULT\Control Panel\Desktop\WaitToKillAppTimeOut
    HKEY_CURRENT_USER\Control Panel\Desktop\HungAppTimeOut
    HKEY_CURRENT_USER\Control Panel\Desktop\WaitToKillAppTimeOut
    HKEY_CURRENT_USER\Control Panel\Desktop\WaitToKillServiceTimeOut
  3. Restart your computer.

share|improve this answer

In my case it was the AVG Anti-virus Extensions - SafeSearch and LinkScanner. I have disabled both these and set AVG to ignore the "faulty" condition and have not seen any lockups since...

share|improve this answer

There's no problem with FF on Win7, so the problem is specific to your computer.

I suggest to start FF with the Mozilla Firefox (Safe Mode) shortcut. If this fixes the problem, then it's some FF add-on that's causing the problem, which you should locate and uninstall.

If the problem still exists, uninstall FF, clean-out the installation directory and re-install. It should work, or the problem is more complex and may have something to do with an installed antivirus or another reason.

share|improve this answer
Thanks for the reply Starting in Safe Mode made no difference but uninstalling and reinstalling using Revo Uninst seems to have done the trick. Will carefully re add addins to see if any cause the problem to recur. –  Paul Dec 29 '09 at 11:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.