Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

OK I just can't figure this out. I have an EC2 instance, which I'm able to SSH into just fine with:

ssh -i XXXX.pem ubuntu@XXXX.com

I can even make it slick from the command line by creating a ~/.ssh/config with this in it:

Host XXXX
HostName XXXX
User ubuntu
IdentityFile ~/.ec2/XXXX.pem

Which allows me to simple do a ssh XXXX with no -i option.

Now, I want to mount this via SSH. I've tried MacFuse/SSHFS, MacFusion and ExpandDrive, but no luck. It's supposed to "just work" but the SSH-related command line utilities and the Keychain Access program in OS X is confusing and opaque to me.

From what I've read, these GUI programs don't care about .ssh/config, they care about the Keychain. Somehow I can associate my domain name I'm connecting to with a particular "identity" private key file (.pem file) but I have no idea how. I tried this:

ssh-add -K XXXX.pem

Which does add to the Keychain but it's not associated to a particular domain.

These GUI mounting programs I mentioned all just spin and do nothing when I try to connect passwordless. No keychain prompt, no nothing. I've pretty much given up and I'm thinking about just setting up an SMB server, but I'd rather just go over SSH since I believe it's possible.

share|improve this question

migrated from stackoverflow.com Dec 28 '09 at 3:07

This question came from our site for professional and enthusiast programmers.

1 Answer 1

I figured this out. I just cleared out everything from Keychain Access and .ssh/known_hosts. I think the known_hosts was what fixed it. Previously when I SSH'd in from the command line I got a warning about "mismatched keys" or something.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.