Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've tried to use Windows Explorer (in Windows 7) to connect to a remote FTP site, but when I try to connect Windows says that

The server name or address cannot be resolved

If I try with ftp from the command line, or using FileZilla or a browser it connects with no problem.

Any help greatly appreciated.

share|improve this question
    
tip: if you ever get fed up with Windows Explorer, grab Total Commander and bid farewell to this sad excuse of a file manager. :) Athbhliain faoi mhaise dhuit! –  Molly7244 Dec 28 '09 at 19:14

8 Answers 8

Are you trying to connect by entering the ftp address directly in the windows explorer address bar? Try through the "Map network drive method"...

  1. Click on Start Orb and then click on "Computer".

  2. Click on "Map network drive" from the menu

  3. "Map Network Drive" window will open. Now click on the link "Connect to a Web site that you can use to store your documents and pictures."

  4. Now simply follow the step by step wizard to add a new network location. Select"Choose a custom network location" when given the choice of where to create this network connection.

  5. Type your ftp address e.g. ftp://ftp.yoursite.com. Specify a user name and password if required.

  6. Give your newly created network location

Hope this helps! :)

share|improve this answer

This is possible and configured from the Control Panel -- Internet Options in particular. Go to the Advanced tab and scroll down until you find a checkbox labeled "Use Passive FTP (for firewall and DSL modem compatibility)". Uncheck it.

share|improve this answer
    
Also "Enable FTP folder view (outside Internet Explorer)" –  golimar Jul 11 '13 at 14:09

The possible cause of 'The FTP session was terminated' error may be Windows Firewall settings. Try to turn off Windows Firewall temporary and then enter 'ftp://your.address.here' and see if it helps.

If it helps, than you should probably add Windows Explorer to the list of Firewall exceptions to make it working with FTP.

share|improve this answer

FTP has two modes: active and passive. This is the simplified version, but he passive mode requires an ftp server administrator to leave a large range of ports open, and so many ftp sites prefer to require active. The Windows Explorer FTP client only supports passive. So there you go — odds are you're looking at an active-only ftp site, and Windows Explorer just won't work. You'll have to get a 3rd-party client like FileZilla.

share|improve this answer

It's actually quite a bit more simple than the above situations.

Create a shortcut on your desktop, and for the properties, use this: (You can also paste the line below directly into the 'run' box.)

%windir%\explorer (space) ftp://UserName:UserPassW@ftp.yoursite.com

(Break it down as best I can, %windir% is system environment variable for the "Windows" folder, whether it be XP/7/8 and 'explorer' is the default shell for any version of windows. Followed by the the FTP site's URL settings. The username is passed along separated by a colon where the ftp-site-user password gets passed, finally the 'at-sign' (@) tells it which FTP server by sub/domain-name.)

That opens the FTP site, using Windows explorer (NOT IE!) and you can cut/paste all day long.

Mind you, the FTP administrator HAS to know how to configure the permissions on the FTP site, but this works like a charm.

One caveat, you cannot use an "at-sign" or a colon as part of the user's password, obviously because it's what's denoting/separating the user's credentials from the FTP URL.

share|improve this answer
2  
Bad idea...leaving your password in plaintext –  Kruug Aug 15 '13 at 13:55
    
Well..., @Kruug. ;-) –  Arjan Aug 15 '13 at 14:01

type in 'ftp://server.name.domain' and done.

share|improve this answer
    
It still does not connect, windows explorer says that 'The FTP session was terminated'. If I copy the same URL and use it in explorer I get prompted for username and password. Is there a setting that disables remote/ftp access in windows explorer ? –  Liam Dec 28 '09 at 16:01
    
with 'use it in explorer' you mean 'use it in the browser called "internet explorer"' ? –  akira Dec 28 '09 at 16:54

You could also try "ftp://username:password@ftpserveraddress".

share|improve this answer
    
Same issue as previously mentioned explorer returns 'The FTP session was terminated' –  Liam Dec 28 '09 at 16:10

Alternate method in Windows 7

If you want to upload files, delete files, or rearrange the folder structure on an FTP site, you need to open the site in Windows Explorer. If you just want to open FTP sites and download files from them, you can use Internet Explorer. Here's how to create a shortcut to an FTP site so that the site will automatically open in Windows Explorer:

To create a shortcut to open an FTP site in Windows Explorer Click to open Computer.

Right-click anywhere in the folder, and then click Add a Network Location.

This displays the Add Network Connection wizard. Click Next.

In the wizard, select Choose a custom network location, and then click Next.

Enter the name of the FTP site, with the full FTP:// in front of it, and then click Next.

To use a name and password, clear the Log on anonymously check box. Type a user name, and then click Next.

By default, the name of the shortcut is the same as the FTP address. If you want to give the shortcut a different name, type it in the Type a name for this network location box. Click Next.

If you do not want the FTP site to open after you're done setting up the shortcut, clear the Open this network location when I click Finish check box. Click Finish. A shortcut to the FTP site appears in the Computer folder. You can drag that shortcut to your desktop so that it's easy to find later.

Notes When you first connect to the FTP site, you’ll be prompted for a password. Select the Save password check box if you want Windows to remember that password and connect you directly to the site in the future.

Found here http://www.sevenforums.com/network-sharing/41593-ftp-integration-into-windows-explorer.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.