Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I started updating a bunch of my iPod touch apps I realised there was too much to download over WiFi so I paused the updates, downloaded them with iTunes and synced my iPod.

Since then I have a bunch of grey icons that say 'Waiting' that I can't delete. I've tried syncing and restoring from an earlier backup, but that hasn't worked. Is there any way to get rid of these without doing a full restore through iTunes?

alt text

share|improve this question

closed as off-topic by Journeyman Geek Sep 30 '15 at 7:44

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question is not about computer hardware or software, within the scope defined in the help center." – Journeyman Geek
If this question can be reworded to fit the rules in the help center, please edit the question.

up vote 2 down vote accepted

Well, nothing worked, but two days later I checked the iPod & the icons were gone. I hadn't changed anything, it was like it finally figued out they weren't really applications. Wierd

share|improve this answer

Try deleting these apps in iTunes, re-syncing, and then installing them again from the App Store.

share|improve this answer
Nope, that didn't work unfortunately – Glenn Slaven Jul 20 '09 at 1:01

Short of doing a full restore, you could try going into Settings > General > Reset > Erase All Content and Settings. This should remove everything from your iPod (media, apps and app settings), so do not do it unless you have a backup of all your music.

As long as you have iTunes set to take backups (like it does by default) you should not loose any data. It would just sync back over next time you plug your iPod in.

share|improve this answer
Yeah, I'm trying to avoid loosing all my app data – Glenn Slaven Jul 20 '09 at 1:40
@Glenn - A restore from backup will get you your data back but a restore is a lengthy process. – Chealion Jul 20 '09 at 1:44
Ok, I'll give that a shot, thanks – Glenn Slaven Jul 20 '09 at 4:05

I had the same problem - I think I found the answer though:

When it turns grey and says wait, it probably means that the App Store needs another verification of your password. Click on App Store and the store will probably give you a pop up asking you to type in your password. Enter it and iTunes will probably go back to downloading the game.

If this doesn't work try downloading a new game and type in the password - hopefully it will start downloading again.

share|improve this answer

Try doing a hard reset. Hold down the power button and completely turn it off then hold it again until the Apple appears.

share|improve this answer

protected by studiohack May 19 '11 at 20:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .