Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been running Ubuntu with Gnome for some time now. I wanted to try out XFCE, so I tried the suggestion from the site http://www.psychocats.net/ubuntu/xubuntu and entered the following command:

$ sudo aptitude update && sudo aptitude install xubuntu-desktop 

Unfortunately, this installed not only xfce but also changed the initial login screen. While I can tell the login manager to start a Gnome session, I would like to revert to my previous startup graphics and login manager.

How do I revert back to the normal ubuntu desktop?

share|improve this question

3 Answers 3

you don't have to reinstall ubuntu-desktop, for it is still there: all you have to do is to restore gdm at the startup (instead of the xfce login manager).

It's this info enough for you? I hope so: if not, I'll be here for you! :D

Regards

EDIT: since it could be useful to someone else, here we are. Fire up your terminal and write:

cd /etc/X11

sudo nano default-display-manager

then write inside that file

/usr/sbin/gdm

and close nano with CTRL+X

OR

if you prefer the graphical editor:

cd /etc/X11

sudo gedit default-display-manager

then write inside that file

/usr/sbin/gdm

and save it.

share|improve this answer
    
this shouldn't be necessary. Xubuntu uses GDM by default, AFAIK, so it won't really help. (GDM is not a display manager; it's a login manager.) you probably want to dpkg-reconfigure some package, but i'm not sure which one offhand. –  quack quixote Dec 29 '09 at 1:56
    
> I would like to revert to my previous startup graphics and login manager... –  dag729 Dec 29 '09 at 3:21
1  
I just checked /etc/X11/efault-display-manager. The only contents of the file is the line /usr/sbin/gdm ~quack's comment about xubuntu using gdm seem to be correct. –  pcapademic Dec 29 '09 at 3:52
1  
So I would try to "sudo /usr/sbin/gdmsetup" and I would choose the theme I prefer! :D –  dag729 Dec 29 '09 at 14:43
    
No dice, that line was already in there. –  dawmail333 Mar 20 '11 at 2:44

Try using the Login Screen Settings.

This app can be accessed from the System -> Administration -> Login Screen menut item or from the terminal with the command:

$ /usr/sbin/gdmsetup

Using sudo or gksudo with this command will cause the application startup to fail.

NOTE: In Ubuntu 9.10, the gdmsetup will not allow the change of the startup graphics. From the screenshot, one can see that there is no option to change this:

Login Screen Setting dialog box, Ubuntu 9.10

share|improve this answer
    
This was dag729's second suggested answer, but she left it in the comments rather than posting the answer. –  pcapademic Dec 29 '09 at 21:55
    
Unfortunately, the Login Screen Settings only seems to provide for auto-login vs. gdm menu login. –  pcapademic Dec 29 '09 at 22:00
    
Can you post a screenshot of the /usr/sbin/gdmsetup? You can use uppix.net to append the image. This is what happens to me when I do /usr/sbin/gdmsetup: uppix.net/a/5/d/5a90751bf25ffb0ea4892886224d1.png . –  dag729 Dec 29 '09 at 22:23
    
I tried to upload the following screenshot, but the image is not displaying: uppix.net/2/a/c/b897b21ab533aebd8601dbdbc4d04.html –  pcapademic Dec 30 '09 at 0:46
up vote 0 down vote accepted

I found something that works, from this page "Getting Back to a Pure Gnome on Ubuntu"

Basically, what you need to do is figure out all the packages that were installed by xubuntu, remove those packages, and then reinstall the ubuntu-desktop metapackage.

Some ways to achieve this:

Method 1

A. Use the command suggested on "Getting Back to a Pure Gnome on Ubuntu" page:

sudo apt-get remove a2ps abiword abiword-common abiword-help abiword-plugin-grammar abiword-plugin-mathview abiword-plugins app-install-data-commercial catfish exaile exo-utils feh fortune-mod fortunes-min giblib1 gigolo gnome-app-install gnumeric gnumeric-common gnumeric-doc gtk2-engines-xfce imagemagick libaiksaurus-1.2-0c2a libaiksaurus-1.2-data libaiksaurusgtk-1.2-0c2a libexo-0.3-0 libgdome2-0 libgdome2-cpp-smart0c2a libgnomecups1.0-1 libgnomeprint2.2-0 libgnomeprint2.2-data libgnomeprintui2.2-0 libgnomeprintui2.2-common libgoffice-0-8 libgoffice-0-8-common libgtkmathview0c2a libid3tag0 libimlib2 liblink-grammar4 libotr2 libots0 libpolkit-dbus2 libpolkit-gnome0 libpolkit-grant2 libpolkit2 librecode0 libscim8c2a libt1-5 libtagc0 libthunar-vfs-1-2 libwv-1.2-3 libxcb-keysyms1 libxfce4menu-0.1-0 libxfce4util4 libxfcegui4-4 libxfconf-0-2 libxmlrpc-core-c3 link-grammar-dictionaries-en mousepad orage pidgin pidgin-data pidgin-libnotify pidgin-otr policykit policykit-gnome psutils python-cddb python-mmkeys python-mutagen ristretto scim scim-bridge-agent scim-bridge-client-gtk scim-gtk2-immodule scim-modules-socket scim-modules-table scim-tables-additional tango-icon-theme tango-icon-theme-common tcl thunar thunar-archive-plugin thunar-data thunar-media-tags-plugin thunar-thumbnailers thunar-volman thunderbird ttf-arphic-uming ttf-liberation usb-creator usplash-theme-xubuntu vim-runtime wdiff xchat xchat-common xfce4-appfinder xfce4-battery-plugin xfce4-clipman-plugin xfce4-cpugraph-plugin xfce4-dict xfce4-fsguard-plugin xfce4-mailwatch-plugin xfce4-mixer xfce4-mount-plugin xfce4-netload-plugin xfce4-notes-plugin xfce4-panel xfce4-places-plugin xfce4-power-manager xfce4-power-manager-data xfce4-quicklauncher-plugin xfce4-screenshooter xfce4-session xfce4-settings xfce4-smartbookmark-plugin xfce4-systemload-plugin xfce4-terminal xfce4-utils xfce4-verve-plugin xfce4-volumed xfce4-weather-plugin xfce4-xkb-plugin xfconf xfdesktop4 xfdesktop4-data xfprint4 xfswitch-plugin xfwm4 xfwm4-themes xubuntu-artwork xubuntu-artwork-usplash xubuntu-default-settings xubuntu-desktop xubuntu-docs xubuntu-gdm-theme xubuntu-wallpapers && sudo apt-get install ubuntu-desktop 

B. Reinstall any packages that you want which were removed by command. Remember that some packages that you wanted to keep will be removed because the command removed a dependency. In my case, I had to reinstall

  • xchat (directly removed by command)
  • thunderbird (directly removed by command)
  • vim-gnome (vim-runtime had been removed)
  • timer-applet (didn't go down the rabbit-hole as to why for this one)

One obvious problem with this method this that one may find problems with applications that are rarely used. There may be more problems as well.

Method 2

A. Figure out exactly what packages were installed on your system when you installed xubuntu-desktop, and remove only those packages

More details to follow. Some months ago, I found a neat script that would parse the dpkg log files (/var/log/dkpg.log*) and provide a list of packages installed and removed and when. I need to find that again.

Method 3

A. Edit the gdm theme using the instructions from this site:

http://www.ubuntumini.com/2009/09/hack-karmics-gdm-login-screen.html

  1. Logout of your current session and return to the GDM
  2. Switch to the tty command line prompt using Ctrl-Alt-F1
  3. Login using your normal login/password
  4. at the command line prompt type: export DISPLAY=:0.0
  5. then type: sudo -u gdm gnome-control-center
  6. Switch back to the gdm screen using ALT-F7
  7. The gnome-control-center should be loaded. Use it to configure your GDM.
  8. Click on the Appearances icon, in appearances you can change your GDM's font, theme and background image.
  9. Close the gnome-control-center and login normally.

Of course, you would need to know how the Ubuntu standard gdm was configured to use this method. Or you could just go crazy and have fun with it.

share|improve this answer
1  
if you read through that huge list, note that xubuntu-gdm-theme is really the only one you'd need to remove (in addition to xubuntu-desktop). but i expect there's a way to set Ubuntu's primary GDM theme as standard without totally removing Xubuntu's installed theme. –  quack quixote Dec 30 '09 at 22:25
    
What about "sudo dpkg-reconfigure gdm" or "sudo dpkg-reconfigure ubuntu-desktop" ? –  dag729 Dec 30 '09 at 22:31
    
I tried the sudo dpkg-reconfigure ubuntu-desktop and it didn't work, although, as ~quack noted, I still have xubuntu-gdm-theme installed. I didn't try sudo dpkg-reconfigure gdm, so I don't know. Short of reinstalling xubuntu, I wouldn't be able to test it now. –  pcapademic Dec 30 '09 at 22:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.