Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My wife has just had a new computer for Christmas (with an upgrade from VISTA to Windows 7), and has joined the home network. We are using a mix of WindowsXP and Ubuntu boxes linked via a switch. We are all in the same workgroup. (No domain).

Internet access, DHCP, and DNS server is an SME server that thinks it is domain controller (although we are not using a domain).

I need to run a script to back up my wife's machine (venus). In the past the script creates a share on a machine with lots of space (leda), and then executes the line.

PSEXEC  \\venus -u admin -p adminpassword -c -f d:\Progs\snapshot.exe C: \\leda\Venus\C-drive.SNA

With the wife's old XP machine, this would run the sysinternals utility, copy shapshot,exe to her machine and run it, which would then back up her C: drive to the share on leda.

I cannot get this to work with Windows 7, nor can I link through to the C$ share on her machine. This gives me a permissions error (system error 5). The admin account is a full admin account. And yes - I do know the password.

The ordinary shares on her machine work fine!

I guess I'm missing something that Microsoft have built into Windows 7 - but what? The machine is running Windows 7 business, with windows firewall, AVG anti virus, and all the crap-ware you get with a new PC removed.

Thanks

share|improve this question
add comment

migrated from stackoverflow.com Dec 29 '09 at 1:26

This question came from our site for professional and enthusiast programmers.

4 Answers

In Win7 (and Vista I suppose) command processor is launched with lowered privileges - not with admin rights. You have to explicitly run it as admin. I faced with similar issue right now when attempted to create users from batch file. Running batch thru "Run with admin rights" worked fine. Hope this helps.

share|improve this answer
add comment

Windows Vista and 7 has made many changes in relation to network security.

I really cannot recommend anything with regards to PSEXEC, simply as I have never used it in a non-domain environment, however one of your points was about the c$ share, and I can help there.

I had this problem in Vista, and it is a feature, not a bug. To enable it:

Launch Registry Editor

Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\system\

Create a new DWORD Entry called LocalAccountTokenFilterPolicy

Edit it and put the value of 1

Restart your computer

You should now be able to access system shares.

Edit - Does PSEXEC do anything? At this point, I am not sure if it is PSEXEC itself or a permission issue with the backup utility. Can you try and do something simple like launch notepad? If not, it is probably a permission issue with PSEXEC, if you can launch notepad, it is probably a file level permission with the backup utility.... If you can write in comments and feedback, I will try to edit this and help you after

share|improve this answer
add comment

I've set that entry up (on venus) noting that System has a capital S, and rebooted, but I still cannot connect to c$. This is what happens.

C:\Documents and Settings\Ian>net use \\venus\c$
The password is invalid for \\venus\c$.

Enter the user name for 'venus': admin
Enter the password for venus:
System error 5 has occurred.

Access is denied.


C:\Documents and Settings\Ian>

There is a rather long pause after entering the password, before the System error 5 is returned.

share|improve this answer
    
Its a permissions problem - and I still have no ideas how to solve. Anybody? –  Ian Jan 3 '10 at 0:02
add comment

This is a permissions problem.

My first guess would be that it has to do with the fact that under Win7 the Guest user is no longer part of the Everyone group. Therefore, I would verify that this account is enabled and give it Full Control permissions over the share in question. However, with all the security enhancements in Win7, this might not be enough.

Secondly, I would verify that in the following registry key
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
the value of RestrictAnonymous is 0.
RestrictAnonymous controls whether null sessions, sessions that work without any authentication and use the permissions of the groups Everyone and NETWORK, are allowed (value 0) or disallowed (value 1).

Thirdly, I would look for an alternative solution to using PSEXEC. There are many file-syncing programs out there that might not trigger Win7's defense mechanisms.

share|improve this answer
add comment

protected by Diago Nov 23 '10 at 16:52

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.