Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm at my wit's end trying to control SMB file sharing on my Mac. (OS X 10.5 Leopard).

I want to do something fairly simple: share a particular (non-home, non-Public) folder over my my SMB/Windows network with two users (accounts are local to my Mac), and share no other folders with anyone.

The instructions on the internet are fairly straightforward: add the folders to be shared to the File Sharing panel of the Sharing System Preferences pane:

Sharing

..and ensure that I'm sharing through SMB:

System Preferences

However, when I actually try to connect via a SMB client (Windows XP in this case), the share does not appear. I see my home directory, "Macintosh HD", and my printers, but not the folder I just shared.

I ensured that the underlying directory had the proper permissions (since this seems to affect share visibility) and that the "Shared Folder" checkbox was checked:

alt text

...but this didn't have any effect.

I checked /etc/smb.conf but there was nothing obviously out of place there. I've also restarted smbd and rebooted.

What else should I be looking for?

share|improve this question
    
how about embedding them screenshots? –  Teflon Ted Dec 30 '09 at 0:15
    
I tried that (check the edit history) but I think my rep is too low to allow that. –  Craig Walker Dec 30 '09 at 7:46
2  
I embedded the pictures for you. –  Josh K Mar 29 '10 at 2:30
    
Cool thanks @josh –  Craig Walker Apr 8 '10 at 3:54

4 Answers 4

Try setting a workgroup on the mac and the pc that is the same. On the mac it is set with system preferences for the network adapter. You could also try connecting by IP address instead of name.

share|improve this answer

I recommend you check out a program called SharePoints. It works perfectly on my server running Mac OS X! :)

share|improve this answer
    
Unfortunately SharePoints doesn't work with Leopard: hornware.com/faq/index.php?qid=23&frommostrecent=yes –  Craig Walker Dec 29 '09 at 7:53

My first guess was that the XP machine isn't supplying a username/password, so OS X is only showing it the "guest"-readable shares - but you say it's showing your homedir, so that musnt' be the case.

My second guess is that the Samba hasn't been restarted and so the daemon hasn't seen the new share. Turning off SMB sharing and then turning it back on should fix this.

My third guess is that it's something else.

share|improve this answer
    
I actually had rebooted, but forgot to mention it. I've edited the question to reflect this –  Craig Walker Dec 29 '09 at 16:58

That is the intended behaviour using OSX to share on SMB. The other folders will be unavailable, but the user must navigate to the folder they ARE allowed to access

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.