Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On one of my XP boxes, I have one user account. Currently, when I boot up the computer, I have to go to the welcome screen, enter the user's password, and log in. Right now, I removed the password, even though I haven't yet tried rebooting to see if the following problem has been avoided.

My question is, how can I disable the welcome screen and automatically log into an account? I have a feeling this is a setting in Local Security Policies, but I'm not sure.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

bypassing the welcome screen - copy pasted :-)

Bypass The Windows XP Log On Screen

To make logon an unattended process:

Click [Start] [Run] and type control userpasswords2
Click [OK]
The [User Accounts] Property Sheet displays.
On [Users] tab, clear the [Users must enter a user name and password to use this computer] check box.
Click [Apply].
Enter a user name and password that should be used to logon automatically in the dialog box that appears.
Click [OK].
Go to [Control Panel] [User Accounts] [Change the Way Users Log On and Off].
Uncheck [Use the Welcome Screen] and [Use Fast User Switching]

Leave a comment if it doesn't work.

share|improve this answer
1  
Disabling Fast User Switching and The Welcome Screen should not be necessary. My own account has skipped the welcome screen since I installed XP, and I while thumbing through the control panel to attempt to find the preference that causes it, I noticed that I still have both of these checked. –  Emory Bell Dec 29 '09 at 3:43
    
It works - thanks so much for the elegant solution! –  Maxim Zaslavsky Dec 29 '09 at 3:50
    
I think this is a kind of a general solution, which should fit all. I'm not sure about the details, but at my place the situation differs. I never did anything, and am also the only user on my machine, but the logon screen has always been there by default. (sp2 xp). In any case, problem solved for now. –  ldigas Dec 29 '09 at 4:08

I haven't found anything special I've done to bypass the Welcome Screen on my own box (which has bypassed it by default since I installed it), so removing your password should do the trick. I would suggest going ahead and restarting--you've likely already solved the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.