Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My understanding is that in Windows 7 if I right click an ISO image I should have an option Burn Image, or if I double click an ISO I should get a dialog to let me burn the image....

Not happening for me, any idea's why?

Edit: 29th April.

I do have isoburn.exe in my system32 directory, and it works just fine if I launch it manually from cmd. However I simply do not have the context menu when I right click on a iso file.

So my more specific question is, does anyone know how to simply restore this context menu item, an entry in the registry perhaps? (but where and what)

share|improve this question

6 Answers 6

up vote 47 down vote accepted

The above will work but an easier fix in Windows 7 is to go to control panel, select "default programs" then select "associate a file type or protocol with a program", this will display a list of file types, select the ".iso" file type then press the "Change Program" button, then select "Windows Disk Image Burner". If it's not in the list, browse to C:\Windows\System32\isoburn.exe. Press "OK". All done. Right clicking an iso file will now display "burn disk image".

share|improve this answer
My clean install of Windows 7 was showing the same behavior that Tim Jarvis saw. After using the tip from Alberto, the "burn disc image" choice began appearing in the right-click menu for iso files. Strange that this wasn't a default setting. Thanks. – user67381 Feb 12 '11 at 22:27

Have you installed any other CD\DVD burning softwares? If so, it could be that they've associated themselves with ISO files. Try selecting the file, then right clicking it, then selecting "Open With" and see if Windows Disc Image Burner is one of the selections. If it is, just select it as the default program to open ISO files with with.

share|improve this answer
no, its a clean install. – Tim Jarvis Jan 5 '10 at 4:51
This fixed the problem for me. I didn't think I had any other software associated with ISO images but re-establishing the association did the trick – tonylo Feb 25 '10 at 17:49
Glad it helped somebody. – joeqwerty Feb 26 '10 at 13:33

I tried the above fix, but .iso wasn't in the list of available file types. Right clicking on the iso file, selecting properties -> Open With allowed me to select Windows Disk Image Burner. Afterwards, the context menu contained the correct options and the .iso file type was available in the Default Programs list.

share|improve this answer

Yes, changing the file association by right-clicking the .iso and doing it in the Properties was the way I solved the problem. No other software was on my system as the default CD burning app nor was .iso in the file association list.

share|improve this answer

Good answers and comments; My comprehensive take on this question,and generalising, may I give a set of instructions building on previous answers to solve the problem?

In Windows 7, to force an Open With... to appear on the context menu (if it doesn't already!) when right-clicking a file, do the following:

  1. Right-click on the file.
  2. Choose Properties.
  3. At the end of the line which starts Open with:, click on the Change... button.
  4. Click on the 'v' chevron to open up Other Programs.
  5. If the default program is not on the list shown, click on the Browse button.
  6. You will now have to search for the utility program that you require to open the file. e.g. to process an ISO file, the utility required is: Windows Disc Image Burner and the program file to do this is isoburn.exe which is in the C:\Windows\system32 folder.

    Select this file and click OK. This will put an Open with... on the context menu, and also cause the ISO file to select the Windows Disc Image Burner application as the default.

Information on what executable file does what can usually be found by searching the web.

share|improve this answer

A simple workaround is to change the extension of the file, from .iso to .img.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.