Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have had this problem before and fixed it, but I don't recall how I did it and I did not record it (sadness :( )

I have all the requisite commands installed on OpenSuse to support gparted's efforts in creating any of the supported file systems. I recall that the problem was that gparted could not find the commands, in any event all the file systems are greyed out in the context menu except for the legacy hfs partition which only supports < 2gb. Even extfs2-extfs4 are greyed out.

How do I fix this?

share|improve this question
    
Yes - I am running gparted with root privs through gnomesu. –  cmdematos Dec 29 '09 at 4:19
    
Make sure all the filesystems are installed, search them in yast and install them or reinstall them. Also check the MD5 of the disk, it could be a bad disk. –  alpha1 Jun 2 '10 at 3:47

3 Answers 3

Have you tried booting with a Linux Live CD / Gparted Live CD to see if this happens still?

share|improve this answer

Are you trying to modify a mounted partition? Unmount it and then try running gparted.

share|improve this answer
    
This is really a comment, not an answer to the question. Please use "add comment" to leave feedback for the author. –  Diogo Aug 9 '12 at 12:46

I've installed:

gilberto@SUGEP-DMASI:~> rpm -qa|egrep 'gparted|ntfs'
ntfs-3g-2009.4.4-3.2.1.i586
ntfs-config-1.0.1-291.1.i586
gparted-0.4.7-1.pm.1.2.i586
ntfsprogs-1.13.1-109.2.i586
gilberto@SUGEP-DMASI:~>

However when trying to use it from the menu item like you, it was grayed out. The problem occurs because it runs with the user's settings and not with root's. The workaround is:

  1. Start a user terminal
  2. From the user terminal became root (don't forget the signal):

    gilberto@SUGEP-DMASI:~> su -
    Password: 
    SUGEP-DMASI:~ # gparted
    ======================
    libparted : 1.9.0
    ======================
    
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.