Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on a Windows 7 Computer with an additional Windows 7 computer and an XP computer and I keep getting an error: 0x8007046a: "Not enough server storage is available to Process this command" when I try to connect to a share on the Windows XP Computer. The Windows 7 Computers talk fine as far as Homeroup, etc, but no dice with XP shares. Additionally this is in a workgroup.

I have searched countless forums including TechNet, tried IRPStackSize, DhcpNodeType, and Uninstalling/Reinstalling File and Printer Sharing for M$ Networks. Any help is much appreciated.

share|improve this question
    
Have you confirmed that your Windows 7 machines/users have permissions to the Windows XP share? –  Mark Dec 29 '09 at 13:13
    
As of now I'm using Simple File Sharing in WinXP, will that not work with Windows 7? –  user22938 Dec 29 '09 at 16:24
    
Ok, I have WinXP Home installed on the computer that I'm trying to access. I went to folder options, unchecked the "Use Simple File Sharing" box, and restarted. The sharing dialog box looks no different than before, and I can't find a permissions dialog. –  user22938 Dec 30 '09 at 3:39
    
Make sure you have the correct permission level set. You can read more about it in the section, "Managing levels of access to shares and to files" at this link: support.microsoft.com/kb/304040 –  Mark Dec 30 '09 at 12:29
    
I just can't find a permissions dialog to set permissions.. is there a way to set permission via cmd? –  user22938 Dec 31 '09 at 1:04
add comment

2 Answers 2

Ive seen this before in XP Home, if permissions are set correctly its normally because force guest is set on the XP machine.

  1. From the command prompt on the Windows XP computer, run Regedit.exe

  2. Select the following registry key:

HKEY_LOCAL_MACHINE| SYSTEM | CurrentControlSet | Control | Lsa

  1. Change the forceguest DWORD Value data entry to 0

  2. Click OK.

  3. Exit the registry editor.

  4. Restart the Windows XP computer.

share|improve this answer
add comment

"Not enough server storage is available to process this command"

IRPStackSize should be modified/added to the XP registry, use a value of 15 or 20. Reboot XP PC.

Click Start, and then click Run.

Type regedit and then click OK.

Navigate to the following key:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters

In the right pane, double-click the value IRPStackSize. If the value does not exist, then you must create it. To do this, right-click the right pane while in the Parameters folder of the registry. Point to New, and then click DWord Value.

Type IRPStackSize. It is case sensitive, so be careful to type it exactly.

Change the Base to decimal.

In the Value Data box, increase the value by 15 or 20 then click OK.

Close the Registry Editor.

Restart the computer.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.