Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a new Verbatim 1.5TB USB hard drive (Samsung HD154UI) and I'm finding myself completely unable to fill it. I'm using Windows XP.

Whenever I try to copy a load of files over, it works for some time (will copy over between 20 and 90GB) but eventually stops with an error saying "The specified path is too deep" - the specified is not too deep, there's nothing more than 2 directories deep that I'm copying. A balloon pops up at the bottom saying "Windows - Delayed Write Failed" telling me the data could not be copied.

This wouldn't be too bad if I could just restart the transfer, but after this error has happened I can't write anything else to the disk - including if I eject it and then connect it to another machine. It just seems completely locked. The only way I can unlock it is to delete everything that I was copying to it.

I've tried various USB cables and copying from different machines, and the same thing keeps happening.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

If you've tried with various USB cables, and the same exact problem occurs on different machines, it's almost time to consider that the device is a) broken or b) poorly manufactured, and not effective.

If you decide a) is likely, take it back to the retailer and exchange for a new one.

If b), take it back to the retailer and ask for a refund, then use the money to buy a different product.

This is not to say there isn't a software solution (maybe there is), but your ability to exercise options a) and b) is somewhat time limited. To my mind, this sort of operation on a modern device and modern computer should just work, and the likelihood of a built-in problem in the device increases with every computer it doesn't just work on.

Before giving up, though, you should:

  • check for updated drivers or device firmware from the manufacturer;

  • search the manufacturer's support knowledge base for this error, to see if there's a simple fix; and

  • test the device on as many computers as possible, with as few other USB devices as possible (to eliminate the possibility of USB bus congestion).

Just know when to give up and take it back for something that works.

share|improve this answer
Ended up taking it back and gettin a new one. Tested it with a 120GB transfer. Transfer failed after 75GB but, unlike before, could just be started again. Didn't lock the drive in a crazy way. Hopefully this will continue. – user22956 Dec 30 '09 at 0:06
well, the transfer failing isn't great, but at least the new drive doesn't lock up completely. same device or did you get a different make/model? – quack quixote Dec 30 '09 at 1:53
I got the same make & model. That failure is the only one I've had since I got it, everything else has run very smoothly and I've been reading/writing large amounts of data with it. Thanks for the advice - saved me a large amount of wasted time & misery! – user22956 Jan 5 '10 at 14:16

I had a similar problem on a vista machine where the drive generally worked but anytime I tried to copy a large amout to it it failed, no error message drive just disappeared. I also had problems where when I first plugged it in it would just click click click and not come online.

I turned of "index this drive for faster searching" and it works fine now. Right click drive, properties/general bottom of page.

share|improve this answer

Turn off Disk caching for that particular drive.

Start at the desktop. Right-click on My Computer, then left-click on Properties. Click on the Hardware tab at the top. Click on the Device Manager button. Click on the + next to Disk Drives to expand it. Right click on the hard drive on which to turn write caching off, then left click Properties. Click on the Policies tab. Click on Enable write caching on the disk to remove the tick. It must not be ticked. Click OK.

This may not resolve the issue completely, but it sounds like something is failing to be written by the cache....

Also try running a checkdisk on your main hard drive, and external hard drive. Something is failing, and it might be your main hard drive...

share|improve this answer
it's very unlikely you'd get Delayed Write errors from the main hard drive during a copy operation to an external drive. it's more likely an issue with the external drive, the drive's USB-to-ATA bridge interface, or the system USB controller – quack quixote Dec 29 '09 at 12:01
Yes, I believe the caching on the external needs to be disabled... But you can't discount a marginal bad sector on the main hard drive giving a read error. I suspect there maybe a bad sector on the external drive... But a little paranoia in this case is needed. I have seen delayed write errors caused when Windows couldn't read the data from the internal (main) drive.... – Benjamin Schollnick Dec 29 '09 at 16:01
Thank you both very much for your quick & helpful answers. I have disabled the write caching, but when I tried to copy files over (this time from a different machine), it failed after about 60GB and I was once again left unable to copy anything else to it. I attached it to yet another machine (that it had not been attached to before), it went through the "install new hardware" process and that left me able to copy files to it again. Wasn't long before it pulled it's you-will-not-write-to-me trick again. I am thinking the drive must be defective, it's failed on 3 machines so far ... – user22956 Dec 29 '09 at 18:02
Sounds like a defective drive / external case then if it's failed on multiple systems... Exchange it, or replace it, if possible. – Benjamin Schollnick Dec 30 '09 at 4:38
Quack, we are having a slight communications problem... I have seen delayed cache write failures, when the bus can't keep up with the data transfer from the main drive to the external. I have seen it as well, when there's been an error on the main drive, and thus it can't write the data to the external drive. It sometimes shows up a delayed cache write failure on the external drive. Windows can be funny about error reporting. – Benjamin Schollnick Dec 30 '09 at 4:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.