Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've enabled my second monitor, works great (even though I don't want to use it, but that's another matter)

Now, the background on both displays is... not what it should be, i.e. the background picture from the selected theme. The primary display is something blackish (black and grey stripes), and the secondary is just black.

Tried changing themes, with no effect (on the background, the rest of the UI changes correctly).

EDIT: Card 1 is a Radeon 4650, 1GB, card 2 is a 4350, 512MB. Driver is 9-11 (or maybe new, Windows Update did some updating). Manually setting the background doesn't work either.

Windows 7 is the x64 variant. Box has 4GB of memory. CPU is an Athlon II X2 245. No overclocks.

EDIT: Started the performance check (updating "Windows Experience Index") and suddenly, both minitors show the manually set image. *headscratch*

Had a reboot while running the test, and on restart, it works perfectly. One could think I forgot a reboot, but why did the performance test seem to fix things, then?

share|improve this question
    
Can you post more details on your machine - graphics card, memory etc. –  ChrisF Dec 29 '09 at 16:18
    
Did you try changing your desktop background separately? –  anand_trex Dec 29 '09 at 16:28
    
Is it just the background going screwy on the one monitor? I have a similar issue with my Win7 laptop where the laptop's screen goes black and turned off after I attach an external monitor. Mine traced back to win7 identifying my video card correctly, but installing the wrong driver for it. Manually installing a corrected driver solved my issue. Still not perfect but much better. My workaround when that screen goes off is flip the lid down and back up, causing the screen's power to cycle off and back on, causing the main monitor to come back to normal state. –  BBlake Dec 29 '09 at 19:34
    
I'd probably have tried the lid-flipping thing... if this was a laptop. ;-) –  Jürgen A. Erhard Dec 30 '09 at 1:42
add comment

1 Answer

up vote 1 down vote accepted

Glad to know that the problem is fixed. If that ever happens again, open up task manager (right-click the taskbar or CTRL-ALT-DEL) and go into the "Processes" tab. Within there, you will find a process named "dwm.exe". End that process and it should start right back up by it self and everything will be back to normal.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.