Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sometimes when I start an application with admin rights the modal dialog box that requests my permission to continue becomes hidden. I'm forced to press ctrl-alt-delete and start task manager so I can bring the dialog to the foreground.

How can I fix this so that the permission to continue dialog is always in the foreground?

And anybody know how I can find a Microsoft Engineer to kick for deliberately retarding an operating system so that it is obsoleted by decades-old versions?

share|improve this question
2  
I'm thinking of writing a movie called "Back to the Future" where a kid goes back in time to find technology that actually works! –  PP. Dec 29 '09 at 16:22
    
go to a shop, buy windows 7, get back and upgrade Vista? –  Jonathan. Dec 29 '09 at 16:46
    
While yes, this is annoying and it should never happen, UAC is otherwise vastly superior to XP's "Everyone has everything! :D" security policies. –  Phoshi Dec 29 '09 at 21:35
add comment

2 Answers

If a program other than the foreground program requests elevation, instead of interrupting your work (the foreground task) with a UAC dialog box prompt, UAC signals its request with a flashing taskbar button. Click the taskbar button to see the UAC prompt.

Apparently, the idea is that UAC prompts will not “steal focus” from the user’s task. You should click on the flashing icon.

This is not all Microsoft's fault. Some products are badly programmed, so although their window is the current focus, they don't pass that window's handle for UAC to use. In that case, UAC will not put its dialog in front, but will rather signal its presence thru the taskbar.

And for the last question: Microsoft Engineers are mostly found in Microsoft Way, Redmond, Washington.

EDIT

You might check if in Local Security Policy (or run gpedit.msc) / Local Policies / Security Options, the value of "User Account Control: Switch to the secure desktop when prompting for elevation" is set to Enabled.

share|improve this answer
    
Frequently, as you describe, a task will flash in my taskbar for the dialog requesting my permission; however clicking on it won't bring it to the foreground. I have to ctrl-alt-delete, go to task manager, and switch to it. –  PP. Dec 29 '09 at 19:06
    
Please see my edit above. –  harrymc Dec 29 '09 at 21:31
    
Thanks for your edit; I tried looking for the "Switch to the secure desktop when prompting for elevation" setting in the policy to registry key spreadsheet found at go.microsoft.com/fwlink/?LinkID=54020 but couldn't. As I'm using Vista Home Premium there is no gpedit.msc. –  PP. Jan 6 '10 at 19:07
    
This article tells how to change this in the registry : technet.microsoft.com/en-us/library/…. –  harrymc Jan 6 '10 at 19:15
add comment
up vote 0 down vote accepted

In order to choose a "correct" answer I have to make this post: there is no answer. Perhaps superuser.com should have an option to specify a question as unanswerable particularly when it comes to Microsoft products.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.