Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can detect my wireless network - but I can't connect. My wireless was working until I turned it on this morning.

  • I have 3 wireless devices: an XP, a Windows 7 and an iPhone and none of them are working
  • My router is a LinkSys WRT150N. Both the Internet and Wireless lights are on. To make it easier to debug, I have turned off the wireless security and the Mac address filter
  • This is definitely not an Internet problem - my wired computer has perfect Internet access
  • Resetting both the router and the computers had no effect

Any suggestions?

(Question has been updated in response to the answers)

share|improve this question
    
minor correction; the WRT150N is a router not a modem. –  RJFalconer Dec 29 '09 at 23:42
add comment

3 Answers

up vote 3 down vote accepted

Some possibilities to check;

  1. Your router has no IP addresses left to assign.
    Log on to the admin interface (as per skypecakes's answer) and increase the range of addresses.

  2. None of your wireless devices support the channel the wireless is broadcasting on.
    Change the channel to a more common one (say, 6).

  3. Router has gremlins.
    Reset router to scare off gremlins.

share|improve this answer
    
Good call on the gremlins! Never hurts to try a reset. –  skypecakes Dec 29 '09 at 23:50
2  
<3 =). And remember kids, it's important that routers (like gremlins) don't get wet. Probably shouldn't feed them after midnight either. –  RJFalconer Dec 30 '09 at 0:19
    
Thanks! Changing to channel 6 worked. Strange since channel 11 was definitely working before –  Casebash Dec 30 '09 at 1:49
    
Sometimes you just have to change the channel that base station operates on. –  Mike Chess Dec 30 '09 at 6:00
add comment

(After rereading your question, looks like you have already done this part; but for others reading this question, I'll leave it in.)


Go to the admin web page for the router from the wired computer. Usually it's something like http://192.168.1.1, where 192.168.1.1 is the IP address of the router. To find out the router IP address, go to a command prompt and type "ipconfig /all." Look for a line that says "DHCP Server." This will be the IP address of the router.

Check the wireless settings there. Then configure each wireless device to match those settings. If encryption is turned on (it should be!), you will need a passcode/password from the admin page. In general you will be prompted to type it in to each wireless device when you attempt to connect for the first time.


If you received the router from someone else, or if you may have inadvertently changed some setting, try resetting the router to factory defaults.

Are you prompted for a passcode when you attempt to connect? What error message do you get, if any, for each of the wireless clients?

I suggest renaming your wireless network (SSID) to something unique, and then make sure when you are browsing for wireless networks that the name change is reflected. That will eliminate the possibility that you are connecting to someone else's router.

For Network Mode, make sure you have selected "Mixed" or "Wireless-G only." (iPhone doesn't support wireless-N.)

share|improve this answer
    
How do you do the horizontal lines? –  Casebash Dec 30 '09 at 1:51
1  
@Casebash; "---", "___" or "***". See also; meta.stackexchange.com/questions/3122/formatting-sandbox (scroll down to the 3rd answer) –  RJFalconer Dec 30 '09 at 2:17
    
I did it by accident... typed in some hyphens to split up my response and I was pleasantly surprised! –  skypecakes Dec 30 '09 at 2:19
add comment

Just a note on picking channels in areas that have other 802.11 networks setup. If you are using b/g you will see best results by choosing a channel that is not in heavy use in your environment. Use a utility such as inssider to find this information out. Once this is determine pick either channel 1, 6, or 11. Checkout the Wikipedia entry on 802.11 for the reasoning of why those particular channels. The particular information from the Wiki entry is below.

Besides specifying the centre frequency of each channel, 802.11 also specifies (in Clause 17) a spectral mask defining the permitted distribution of power across each channel. The mask requires that the signal be attenuated by at least 30 dB from its peak energy at ±11 MHz from the centre frequency, the sense in which channels are effectively 22 MHz wide. One consequence is that stations can only use every fourth or fifth channel without overlap, typically 1, 6 and 11 in the Americas.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.