Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to start another x session but I can't do it anymore, since I installed the Proprietary ATI Drivers. Apparently it seems to be were the problem is coming from.

Does anyone know how I can have another x session running on ctrl+alt+f1 ?

I have tried startx -- :1

And I get an error:

0: X(xorg_backtrace+0x26) [0x4f00c6]
1: X(xf86SigHandler+0x41) [0x4852c1]
2: /lib/ [0x7feb3caf5530]
3: /usr/lib/xorg/modules/drivers// [0x7feb3b152f21]
4: /usr/lib/xorg/modules/drivers// [0x7feb3b1572a8]
5: /usr/lib/xorg/modules/drivers// [0x7feb3b124df0]
6: /usr/lib/xorg/modules/drivers// [0x7feb3b1234bb]
7: /usr/lib/xorg/modules/drivers// [0x7feb3b166a88]
8: /usr/lib/xorg/modules/drivers// [0x7feb3b165fb8]
9: /usr/lib/xorg/modules/drivers// [0x7feb3b14762f]
10: /usr/lib/xorg/modules/drivers// [0x7feb3b145ee4]
11: /usr/lib/xorg/modules/drivers// [0x7feb3b144583]
12: /usr/lib/xorg/modules/drivers// [0x7feb3b144635]
13: /usr/lib/xorg/modules/drivers// [0x7feb3b1448c7]
14: /usr/lib/xorg/modules/drivers// [0x7feb3b121c62]
15: /usr/lib/xorg/modules/drivers// [0x7feb3b121848]
16: /usr/lib/xorg/modules/drivers// [0x7feb3b0e93d0]
17: /usr/lib/xorg/modules/drivers// [0x7feb3b0ac72f]
18: /usr/lib/xorg/modules/drivers// [0x7feb3b0ef345]
19: /usr/lib/xorg/modules/drivers// [0x7feb3b0ed6ef]
20: /usr/lib/xorg/modules/drivers// [0x7feb3b0ed85b]
21: /usr/lib/xorg/modules/drivers// [0x7feb3b0ee35a]
22: /usr/lib/xorg/modules/drivers// [0x7feb3b0ec74d]
23: /usr/lib/xorg/modules/drivers// [0x7feb3b0ad5b2]
24: X(InitOutput+0x507) [0x46f017]
25: X(main+0x1fe) [0x433ece]
26: /lib/ [0x7feb3cae0abd]
27: X [0x433509]
Saw signal 8.  Server aborting.
 ddxSigGiveUp: Closing log
 ddxSigGiveUp: re-raising 8
giving up.
xinit:  Connection refused (errno 111):  unable to connect to X server
xinit:  No such process (errno 3):  Server error.

Anyone knows how I solve that?

I want to start an x application using another session/user for some reasons, but this is blocking me

share|improve this question
We know VTs1-6 are text consoles, and you've mentioned 7-9; that still leaves 10-12 that should be free. I assume you've tried startx -- :1 and it's giving you some error message - could you tell us more about what you're seeing? – James Polley Dec 30 '09 at 9:35
unfortunately I have no clue what they did, but F10 F11 F12 are locked it seems. I don't see any ttyl or what ever its called when I switch to it. – mnml Dec 30 '09 at 9:58
I ran this on my Karmic machine; I can get a second X session started on anything from F9 or above as root; but as a normal user, I get complaints from DBUS about the fact that I don't have permissions to own the (from memory) service. These show up on the tty where I ran startx though - nothing happens on the TTY where X would be starting, if it were going to start. – James Polley Dec 30 '09 at 10:02
I just tried or two computers, one is a fresh install of karmic, and another one is an upgrade of previous ubuntu releases. All I get is some logs on F8, and a blackscreen on F9 F10 F11 F12. – mnml Dec 30 '09 at 10:06
Did you try running startx as root (ie, sudo startx -- :1)? That 'works' for me, for values of 'works' that include 'Starts an X session as root, without ever running GDM, so no user other than root can be logged in' - but at least it shows that there's nothing preventing F9 from being used – James Polley Dec 30 '09 at 10:25
up vote 2 down vote accepted

Why not replace gdm with xdm or kdm?

share|improve this answer
Well, that could be a solution but apparently I can't seems to be able to open more than one x-session at the same time. – mnml Jan 4 '10 at 9:52

If you don't really need a totally different X session but could go along with a nested one, try Xnest:

Xnest is an X Window System server that shows its output in a window. In other words, Xnest opens a window that works like another screen in which the user can open windows, etc.

once you're inside you can open a terminal, avoid the whole gdm issue and just get the application started. With the plus benefit of not having to ctrl-alt-Fx every time, the monitor flickering, etc.

share|improve this answer

Urgh, This has led me to discover a world of yuck that I wish I remained ignorant of.

In short, it seems that GDM has been rewritten, and support for running >1 instance of GDM on the same machine has been taken out.

The GDM list has several threads on the work being done to get GDM working again, as well as pointers to in-development sources that have some of the work already done. There's a (closed, because it's an upstream issue) Ubuntu bug as well

So, if multiple GDMs is what you want, you may have to do some work..

share|improve this answer
yeah I don't understand where they are going upgrading their softwares with regressions. Thats like the worse thing they can do imo. – mnml Dec 30 '09 at 9:56

You can't start another X-Session on the same tty, they are associated with each other:

  • F1 -> F7
  • F2 -> F8
  • ...
  • F6 -> F12

But, you could use the User-Applet, and start another session with another account, preserving all logged in users etc.

share|improve this answer
I use the indicator-applet-session (i.e., the user applet) to log on a second x session all the time - whenever I need to quick look up a web page, but my SO is already logged on. – pcapademic Jan 5 '10 at 10:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .