Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This started happening when I installed Windows 7. I've tried with Filezilla and with the FireFTP Firefox plugin, and I could never connect. Filezilla gave the error message "ECONNREFUSED - Connection refused by server". I tried disabling the Windows Firewall, but no luck. Any ideas on what might be causing this?

I just discovered that I can connect with web services like net2ftp, but not with FTP clients.

share|improve this question
    
Are you behind a proxy server of some sort? –  anand_trex Dec 30 '09 at 17:23
    
No, though I do have a router if it matters. It worked with Windows XP though. –  Javier Badia Dec 30 '09 at 17:30

3 Answers 3

Check whether

netstat -na

show you some SYN in line with IP of FTP site. Try to disable all port blocking on router (try to reset settings if you may to restore them after that)
Try to use ftp cmd command and print here all your interaction with the command.
I guess that this already not relevant, because it was 5 mounth ago, so why this question still open?

share|improve this answer
    
Questions do not close because of age. The Community user will auto bump questions that do not have accepted answers to try to get it from the buried pile back to the front so an answer happens. –  MrStatic May 2 '10 at 19:50
    
After some time of not using FTP, I've found that for some mysterious reason it now works. Thanks anyway for bothering to answer this old question. –  Javier Badia May 3 '10 at 17:21

Connection refused by server means exactly that. The server said NO to your attempt. So something else has changed as well. Double check your username and passwords. As well as if the ftp server you are attempting to connect to uses an abnormal port.

share|improve this answer
    
It doesn't work with any server. I tried with many FTP sites, both private and anonymous, and Filezilla just times out. –  Javier Badia Dec 30 '09 at 22:03
    
Times out? That most likely means your isp is blocking the port or something else is. –  MrStatic Dec 31 '09 at 6:12
    
Well, I was thinking it had something to do with the OS, since before install Win7 it worked. –  Javier Badia Dec 31 '09 at 23:44

Is port 21 (the default port for FTP) or Filezilla itself blocked by the Windows 7 firewall?

With XP the firewall was only on incoming connections so you needed a separate program to monitor outgoing attempts. I think it was changed with Vista, but certainly by Windows 7 the firewall is monitoring both incoming and outgoing connections.

So double check the settings to make sure that a) Filezilla is allowed to make outgoing connections, b) port 21 is open.

Using a different FTP client might help confirm this. If that's blocked then is the OS/firewall. If not then it's Filezilla itself.

share|improve this answer
    
Thank you for answering, but for some reason it now works. Thanks anyway. –  Javier Badia Mar 7 '10 at 23:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.