Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have no problem view Apple trailers in little windows, but when I click on a link to download an HD version, it's supposed to load QuickTime, which then buffers the movie and eventually begins to play it.

On my previous computer (Vista/32), QuickTime would wait for a long time (30+ secs) to appear, and sometimes not at all. Sometimes I could short-circuit the delay by clicking the link numerous times, or clicking somewhere else on the page, on another task window, or by pressing Alt-Tab. I'll add that my previous system had three monitors.

My new computer (Win7/64) initially had only two monitors, and QT seemed to load better. Now that I've added a third screen, I can't get it to run at all.

I've Googled about, but not found any solutions. It sound like this guy has the same problem, but there's no response to his message.

Any ideas?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

It looks like I may have found the solution.

I started by checking my task list with Process Explorer from www.sysinternals.com. QuickTimePlayer.exe was parked there, so I killed it.

Then when I clicked on a trailer link, a new instance of QT appeared in the process list, and QT's window appeared as expected. The trailer played, and when it was finished I closed QT.

However, QuickTimePlayer.exe remained in the task list, and no more trailers would play. I killed the task again, and then clicked on a trailer to bring QT up again. This time I went to Edit / Preferences / QuickTime Preferences. On the Streaming tab I turned OFF Instant On.

Now when I exit QT, the player task closes, and a fresh one appears when I play another movie. This is exactly what I want it to do.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.