Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've tried to upgrade my 3GS firmware to 3.1.2 via iTunes, but there was some issue and it couldn't be completed.

My phone is now "stuck" and I can't reset it.

All I have on screen, is a picture of a USB cable, and the iTunes logo, assuming it wants to be connected to iTunes.

I can't switch it off, I've tried doing a hard reset by holding the home button and the power button, but it just loads up with the same screen.

I can't connect it to my PC, its not being recognised when attached

Any ideas?

share|improve this question
up vote 1 down vote accepted

do not try this (Firmaware-Upgrade) in a virtual windows. Me as a Linux-User had to learn this bitter truth...



share|improve this answer
I've just hit this same issue again after trying the iOS4 upgrade. I run fedora and have itunes setup inside a virtual box instance, not good....will only use native windows PC next time – user155695 Jun 23 '10 at 11:34

Have you tried other computers? I guess that's the first obvious solution.

The next is a little more intensive. We need to bring your phone into DFU mode where we can restore with any firmware you'd like. To do so, power off your phone (while connected to your computer and iTunes is open). When shut down, hold the Sleep/Wake button and the Home button for about 10 seconds. After 10 seconds, take your finger off the Sleep/Wake (but keep holding the Home button). Keep holding it until you get a message from iTunes saying that your phone has been detected in recover mode. Restore and try to work from there.

If that still doesn't work, bring it to the Apple store and get that thing replaced since its a 3GS and its still good in its warranty. Just to let you know, I've ran through 3 3GSs already and I'm on my 4th...

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .