Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a number of accounts in Microsoft Office Outlook 2007, a folder for each and a rule which moves message for appropriate folder. Also it have to show a desktop notification.

But it doesn't!

Also I have enabled an option to showing notification for root Incoming folder but 99.99% of my messages goes to sub-folders and absolutely quietly.

share|improve this question

1 Answer 1

up vote 34 down vote accepted

Found this info:

"It only works on the Inbox folder" By default the new New Mail Desktop Alert will only show when the mail is delivered to the Inbox (as the option says as well in Tools-> Options-> button E-mail Options-> button Advanced E-mail Options). This means that when you have a rule configured to move your mail to a different folder the Notification won’t show.

To workaround this you can add the action "display a Desktop Alert" to each and every rule. Besides the fact that it is very tiresome, the real downside of this is that when you are in an Exchange organization the rule will become a local rule so that it will only execute when Outlook is running. This means that when you have added extra actions to the rule, like forwarding it to another address, this action won’t be executed either.

A better solution it to create a generic rule with no conditions and just the action to display the Desktop Alert.

1.Tools-> Wizards and Alerts… (press OK if you get an HTTP warning) 
2.Button New Rule… 
3.Select "Start from a blank rule" and verify that "Check messages when they arrive" is selected 
4.Press Next to go to the Conditions screen 
5.Verify that no condition is selected and press Next 
6.A warning will pop-up stating that this rule will apply to all messages. Press "Yes" to indicate that that is correct 
7.Select the action "display a Desktop Alert" 
8.Press Finish to complete the rule 
9.If needed move the "display a Desktop Alert" rule all the way to the top 

Here: http://www.howto-outlook.com/howto/mailalert2003.htm#always%5Falert

Sounds like what you're running into.

share|improve this answer
    
Thanks for the tip! I will try to use it. Btw, each of my rule has enabled 'show desktop alert'. But it doesn't work. Also doesn't work 'Test alert' in Outlook settings. Why can it be?? –  abatishchev Dec 31 '09 at 0:10
1  
If you're connecting to an Exchange server, then the Rules take on an extra layer of weirdness. There are 'local' rules, which only run in the copy of Outlook you set it up in (like say, making it 'ding' when mail comes in), and then are 'server' rules, which execute at the server, before you get to it via Outlook, and often before it hits your Inbox on the server itself (like Forwarding rules). So if a server-side rule affects the message before the local rule, then often the local rule doesn't have any affect. I hope that clears it up(?) :) –  Ƭᴇcʜιᴇ007 Dec 31 '09 at 0:43
    
Hi. No, no exchange connection. Only a number of GMail/GApps accounts. Thanks anyway for info about Exchange! :) –  abatishchev Jan 3 '10 at 8:56
3  
Glad it helped :) –  Ƭᴇcʜιᴇ007 Jan 7 '10 at 6:19
1  
On Outlook 2010, I had to highlight my "unread mail" folder and then apply the rule for it to take effect. –  SaultDon Jun 26 '12 at 18:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.