Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Even with the new Homegroup feature I'm still finding the way Windows deals with folder sharing utterly baffling. Here's what I want to do.

I have two computers, a PC Desktop and a laptop. I also live in a shared flat with other computer users. I have set up a Homegroup and a Workgroup on the desktop and joined them on the laptop and in the home group I have shared video, music and pictures. This is so that anyone on the network can view pictures and listen to music etc. But I want my Documents folder from my desktop to only be available to me on my laptop and not to anyone else that may be on the network. The Homegroup only allows (from what I can gather from the baffling array of options) sharing with everyone or no one. Is it possible to only allow the laptop to access the documents folder on the desktop? The user name and password are the same on both computers.

share|improve this question

2 Answers 2

After MANY hours of digging to find the answer to this, I finally have it! I was almost driven insane trying to get it to work and it turns out it is really simple.

  1. from the Control Panel, select homegroup and sharing options -> Change advanced sharing settings

  2. Set these options under Home or Work(current profile):

    • public folder sharing [turn on]
    • Password protected sharing [turn on]
    • homegroup connections [use user accounts and passwords]

The homegroup connections option is where the magic happens. All of your personal computers need to have this enabled. You don't need to reset your PC to get it to work, only to log out and log back in, which Windows will automatically prompt you to do.

share|improve this answer
    
Thank You! Thousand times! –  lucek Apr 4 '12 at 12:25

When you right click the folder, go to Share With -> Specific People. Here you can add or remove who has access. You can remove the Everyone group here, and add the computer's local account or any other account you please. Upon trying to access this folder from the share, if homegroup doesn't have access, you should be prompted to log in.

You can also right-click a folder and go to the security tab, where you can configure NTFS permissions and remove HomeGroup from the access control list.

share|improve this answer
    
I had been trying that but I still can't get it to work. When I choose Specific People my local user account is already in the list. But whn trying to access the folder from the other computer I'm denied access. The user account and password are the same on the other computer so I assumed this would work but it doesn't. There is no way of adding non-local accounts in the Share With->Specific People dialog box. Am I missing something here? –  Carbonara Dec 30 '09 at 20:59
    
In network and sharing center, you can change advanced sharing settings. There is an option to turn on password protected sharing ( howtogeek.com/wp-content/uploads/2009/05/turnoffpw.png ). You can make a secondary user account for everyone else and allow them to see public folders, then deny them access to your documents. When you log in to the share, supply your username and password for that remote machine. It will give you access to your shares. –  John T Dec 30 '09 at 21:14
    
Try this. Set up the shared folder as John mentions, then on the remote computer create a new mapped network drive share. In drive pick a letter you want to use, in folder enter \\source_computer_name\shared_folder_name. One of the options when creating the share says to connect with a different user name. Click on this and type in the login credentials for the remote computer, then click finish. I have had this solution work before, but not always, even when my username and password were the same on both computers. –  BBlake Dec 30 '09 at 21:15
    
Thanks for the replies. I've done all of the suggestions bar setting up a mapped drive but it seems to me that i'm missing some setting somewhere. I've turned on Password Protected Sharing and right clicking on the documents folder on the sharing tab it says "Shared" and in the Password protection section it says "People must have a user account and password for this computer etc.". The share shows up on the other computer but when trying to access it i'm not given the option of typing a user and password i'm just flattly denied access... –  Carbonara Dec 31 '09 at 2:14

protected by studiohack Aug 19 '11 at 8:31

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.