Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to set up a dual-head setup on my Kubuntu laptop, and have found several ways to do it. They all seem very complex and I would like to know which one would be best for my situation:

  • Laptop with vga output and lcd internal screen
  • Want different Windows on each screen, no a duplicate output on both displays
  • Need different refresh rates and resolutions on the two displays, since one is a CRT and the other is an LCD
  • Same color depth on both displays is fine
  • Will edit xorg.conf if needed (and have experience doing so), though would like to leave autogenerated config files how the system wants them.
  • Need to be able to boot up and work fine with no external monitor connected

I have tried the KRandRTray application which came with kubuntu, but it just puts the same output on the external display, which is not what I'm looking for.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Warning upfront I am running OpenSUSE 11.2 not Kubuntu. One thing you will need to do is to add virtualto the screen section of your xorg.conf the value should be set to a virtual desktop size that will accommodate both of your monitors. I am running a VGA monitor to the left of my laptop both are at 1024x768 so my setting is

virtual 2048 768

After restarting your X server KrandrTray should allow you to stretch your desktop across both monitors. If this is still giving problems this command should set it up, remember I am using a VGA monitor to the left of my laptop and both are set to 1024x768.

xrandr --output LVDS --auto --rotate normal --pos 1024x0 --output VGA-0 --pos 0x0 --auto --rotate normal

to reverse the positions of the VGA and laptop simply swap the --pos args.

hope this helps.

share|improve this answer
    
This would probably work just fine, the real problem was that KRandRTray insisted on duplicating the displays and would not let me set the position of the second screen and insisted on duplicating the displays. What I ended up doing was using amdcccle to set up the screens and enable xinerama, which is what borked my xorg.conf. I just can't seem to get it back the way it was originally so that I can add the "virtual" line to it. Thanks for the help, though! –  marcusw Jan 1 '10 at 16:43
    
Oh, and when I ran the command after getting the xorg.conf as close as I could to how it was before, I ended up with this output: Xlib: extension "RANDR" missing on display ":0.0". RandR extension missing –  marcusw Jan 1 '10 at 16:44
    
I disabled the proprietary ati driver, changed my xorg.conf to: "Section "Screen" Identifier "Default Screen" SubSection "Display" virtual 2732 768 EndSubSection EndSection" And now it works! Now how to set the refresh rate on the external monitor to 85Hz when kubuntu thinks that it can't handle more than 72.2Hz? –  marcusw Jan 1 '10 at 17:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.