Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a flash drive that was used primarily on a Mac, and it was ejected improperly.

Now when I put it back in, the computer (I tried 2 different Macs and 3 PCs) does not even register the flash drive- it does not show up in Finder or in My Computer. Any ideas how to get the lost files back?

share|improve this question
On a Windows PC, go to Start > Administrative Tools > Computer Management > Storage > Disk Management. Does the flash drive show up there (when plugged in)? Does it show up in device manager when plugged in? – zildjohn01 Jan 7 '10 at 19:42

PhotoRec is file data recovery software designed to recover lost files including video, documents and archives from Hard Disks and CDRom and lost pictures (thus, its 'Photo Recovery' name) from digital camera memory. PhotoRec ignores the filesystem and goes after the underlying data, so it will still work even if your media's filesystem has been severely damaged or re-formatted.

PhotoRec is free, open source and portable (doesn't require installation).

if you're looking for professional data recovery software, then you best bet is WinHex (or the 'light' version Davory)

WinHex and Davory are shareware, try before you buy.

share|improve this answer

First thing I would try is to plug it into another computer - I have no idea why, but ever since floppy drives, this works more often than not.

If it still does not work, you will want to try generic recovery tools.

I recommend Recuva for free, or if you want to pay then R-Studio

share|improve this answer
Same behavior in another computer. I'll try those tools. – Steve Rowe Oct 7 '09 at 4:41
It happens with floppies because of the varying alignment of the drives. It is not so likely with USB where there is no such thing. – Abraxas Jul 23 '11 at 17:19

Assuming it's also not showing in the BIOS when plugged into a system, and since it's not being recognized by the OS(s) you tried, the bad news is it sounds dead. The better news is, it may just be the power sub-system, and the data may still be in the flash memory.

I'd have to say your best bet is to send it off to a professional data recovery place that does flash media. Many (most) offer free evalutation and quotation, you just have to pay the shipping. Most also offer that if in the end they can't get it back, you don't pay.

You can then decide if the recovery fee is worth it, without investing much.

share|improve this answer

If it is not recognised at all (as if device is dead), there are a few ways:

  1. Send to a data recovery company.
  2. Buy an identical stick and swap the memory module across (careful and be quick, had quite a lot of success with this).
  3. Check contacts.

As you said, it is not recognised at all rather than corrupt or not working, this usually means hardware failure more than anything else - so it is worth checking in case it really was yanked out to fast and the contacts broke. If the contacts are fine, it could have just been a cheap stick and has a unknown/cheap chipset, I have seen many that go faulty for all sorts of random reasons and in which case, as I said, moving the memory chip to an identical stick can sometimes fix it.

share|improve this answer

I would really like to reccomend GetDataBack from runtime software. They have two different versions, 1 for FAT32 and NTFS. Despite costing money, they are invaluable tools, on par with Spinrite from GRC(If you are running hdd's), worth every penny.

Previously I have been able to restore files from an ntfs volume which was formatted and had windows reinstalled on top of it, as well as another system which had centOS (linux) partitioned,formatted, and installed over, and was still able to find data on the drive.

share|improve this answer

If none of the other tools work, I would also give a try with Active File Recovery.
There is a limited trial version, so you don't have to pay for it to test it out.

share|improve this answer

I had great success recovering some Nikon RAW image files using:

A very simple process but took 30mins for a 2GB SD card. I did have to do a quick format of the card first so that the OS could see the card as it really was stuffed. This just deleted the file table and doesn't do anything to the actual data, so is reasonably safe to do, but only do this if needed.

share|improve this answer

You must log in to answer this question.

protected by Journeyman Geek Dec 28 '12 at 3:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?