Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I boot my Windows 7 machine, CHKDSK runs.

I have a feeling that the operating system is trying to tell me something, but I don't understand what it is. Any ideas?

Everything works fine so long as I don't reboot.

I treat my computer well, never shutdown with going through Windows "shutdown", etc.

share|improve this question
1  
Your last sentence is a bit ambiguous...if you aren't using Windows shutdown, how do you power off your PC? This could be part of the problem... –  Joe Internet Dec 31 '09 at 4:10
    
Possibly related to your issue is certain software software have caused Windows7 CHKDSK to run too often. Antivir had issues recently - pcpro.co.uk/news/security/353734/… –  Darren Hall Dec 31 '09 at 4:12

4 Answers 4

up vote 4 down vote accepted

The proper way to stop chkdsk from running on startup is to use chkntfs:

chkntfs /x c:

Where c: is the drive you're excluding from the disk check. You can use multiple drives as arguments like so:

chkntfs /x c: d:

Explanation of the various switches:

C:\Documents and Settings\Administrator>chkntfs /?
Displays or modifies the checking of disk at boot time.

CHKNTFS volume [...]
CHKNTFS /D
CHKNTFS /T[:time]
CHKNTFS /X volume [...]
CHKNTFS /C volume [...]

  volume         Specifies the drive letter (followed by a colon),
                 mount point, or volume name.
  /D             Restores the machine to the default behavior; all drives are
                 checked at boot time and chkdsk is run on those that are
                 dirty.
  /T:time        Changes the AUTOCHK initiation countdown time to the
                 specified amount of time in seconds.  If time is not
                 specified, displays the current setting.
  /X             Excludes a drive from the default boot-time check.  Excluded
                 drives are not accumulated between command invocations.
  /C             Schedules a drive to be checked at boot time; chkdsk will run
                 if the drive is dirty.

If no switches are specified, CHKNTFS will display if the specified drive is
dirty or scheduled to be checked on next reboot.
share|improve this answer
    
No explanation for the neg, figures. –  John T Jan 7 '10 at 6:24
    
Sorry, that was me - a while ago. Your suggestion is masking the problem, not solving it. It's like telling someone to turn off the logging of a specific error message instead of dealing with why the message is showing. Also, if you only had a couple upvotes I wouldn't have done it, but I just couldn't handle that many people supporting the idea of ignoring the problem as a fix. –  Ƭᴇcʜιᴇ007 Jan 15 '10 at 4:54
    
Do not forget to run the cmd window as "Run as administrator", otherwise it won't work. Tried it myself, worked like a charm.. –  Gal Goldman Jun 1 '10 at 8:03

If Windows is running CHKDSK at every boot then you have a problem.

Using CHKNTFS to exclude the drives from checks at boot is not a good idea at all, that's just ignoring the problem.

If you are ensuring you always shutdown properly, and it appears to do so, then something is causing the dirty bit to be flagged before power off.

This can be caused by many things (hardware or software), and it's impossible to pinpoint based on what we know. But it's most likely a hardware issue (based on too many years of experience). If you have warranty, save your data and get them to fix it, should be EASY for them if it's happening every time (and they should have all the spare parts available).

If you want to try and diagnose it yourself, then please go try a few things and come back with specific questions.

Hint: try Windows power adjustments, and HDD manufacturer diagnostics to start)

share|improve this answer
1  
I agree that preventing CHKDSK from running is indeed just ignoring the problem. I don't know how the answer got chosen as I am sure the OP asked why it was running and now how to turn it off. I wish you gave more specifics in your answer, though, especially with "please go try a few things". I am having this problem now and would like to know some things to try. –  oscilatingcretin Jul 2 '13 at 11:10

My sister's computer had this, too, running chkdsk on every boot.

She had a virus on her system. We cleaned the hdd, and reinstalled windows and everything to get rid of the problem.

share|improve this answer

John T beat me to the command, but in addition, it is worth noting that this is controlled through "Boot Execute" in Microsoft/Sysinternals Autoruns, you can delete entries there, or go to the registry key they are stored in:

HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\CONTROL\Session Manager

Autochk.exe seems to be there by default - it is just the c: (and any additional drive) parts that you need to delete. The default value for the registry key (incase you delete something by accident) is autocheck autochk *.

share|improve this answer

protected by Ivo Flipse Jan 8 '11 at 16:36

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.