Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Windows 7 Home Premium 32 bit 2 GB RAM Duo 1.6MHz processors

Since upgrading from Vista to Win 7 File Hippo Update Checker no longer works? It appears to go through the motions of checking the software because the popup window appears but it never fires up the results in a browser which it used to do in Vista.

It simply does nothing after the initial popup window appears and disappears.

Have tried uninstall/reinstall with no joy.

Any ideas?

share|improve this question
up vote 6 down vote accepted

Do you have a default browser set? If you press Windows Key + R (or click start and type in Run") and put in a web address like, does it launch a browser?

I don't know what browser you use, but if nothing appears when you try running a web address, do the following steps to set Internet Explorer as your default browser:

  1. Open Internet Explorer by clicking the Start button Picture of the Start button, and then clicking Internet Explorer.

  2. If a message is displayed asking if you want Internet Explorer to be your default browser, click Yes. That's all you need to do.

    If a message does not appear, go to the next step.

  3. Click the Tools button, and then click Internet Options.
  4. Click the Programs tab, and then click Make default.
  5. Click OK, and then close Internet Explorer.

Internet Explorer is now the default web browser.

share|improve this answer
Thanks for the reply. Yes setting a default browser has done the trick – Paul Jan 1 '10 at 13:10

Can't agree with you, I'm using Win7 and my FileHippo Update Checker works fine. Other than that, check if you have set a default browser.

share|improve this answer

You need to turn off User Account Control.

share|improve this answer

Try Filehippo 1.47. I got rid of other versions, did a sweep with CCleaner and Malwarebytes, and installed this version. Works fine. This was recommended on another help board, so I tried it out. I'd never had a problem before this, and now I've got it back. Hope this helps.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .