Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been running Ubuntu 9.10 for a few weeks now without a problem. I installed gloobus-preview which worked wonderfully. Today I updated my computer which also updated gloobus (which patches nautilus to provide some shortcuts). Gloobus stopped working, so I uninstalled it and tried reinstalling it. This included me uninstalling nautilus, removing the gloobus source from the sources, apt-get update, then i reinstalled nautilus. Everything seemed fine, so I reinstalled gloobus. Still had the same problems, so I re-uninstalled it and rebooted my computer. It booted up to the ubuntu login screen as normal, i signed in, then it only brought up a small white terminal screen in the top left corner. Nothing else is started (no window frames, no gnome panels... nothing but the terminal window, and the screen resolution is normal, not super small or anything). i started gnome-session manually and everything came up. Everything seems to work just fine. But I have the same problem every time I restart the computer, i have to manually start gnome-session. I've been googling to try and find a solution but I just can't find anything that helps me. Is there a way to fix this? or a way to figure out what's going on?


share|improve this question

Go into your Gnome session and in the terminal, open ~/.xinitrc (or create it if it isn't there already) using your editor of choice:

$gedit ~/.xinitrc

add this to it:

#!/usr/bin/env bash
exec gnome-session

make the file executable:

$chmod +x ~/.xinitrc

Let's link it to ~/.xsession so it's read by GDM on startup:

ln -s ~/.xinitrc ~/.xsession


share|improve this answer
This didn't work :(. But while doing this, i found two files, .xsession-errors and .xsession-errors.old. the contents of both are this: "/etc/gdm/Xsession: Beginning session setup... Setting IM through im-switch for locale=en_US. Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default." I don't know if that means anything – Joel Jan 1 '10 at 0:17
What does /var/log/messages say? – John T Jan 1 '10 at 0:22 I rebooted my computer and pasted everything that was added to the log starting at the reboot time. – Joel Jan 1 '10 at 6:26

In /etc/gdm/custom.conf add the following line (or edit it if it already exists):


If already in the file it probably reads:


I suppose you could establish emacs instead but I think you want some sort of session manager first.

share|improve this answer
up vote 1 down vote accepted

Finally found a solution - I just typed the following into the terminal and rebooted:

sudo apt-get install gnome-session ubuntu-desktop

All is well now.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.