Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here's a screen shot of my console in an Ubuntu 9.10 desktop live CD installed onto a Windows 7 Windows Virtual PC machine, and then stripped of the X/gnome environment:

enter image description here

Note that the Grub part works fine (I edited /etc/default/grub to use console for output). Once the kernel loads, it switches the graphics card somehow into this dumb mode. What can I do to fix it?

share|improve this question

migrated from stackoverflow.com Jan 1 '10 at 3:14

This question came from our site for professional and enthusiast programmers.

    
good question. just ran into this issue myself, using VirtualPC on winXP. –  quack quixote Feb 10 '10 at 18:28

4 Answers 4

Recent kernels switched to framebuffer devices, maybe the virtual pc cannot cope with that. Two solutions:

  • try the free-as-in-beer VirtualBox emulation software instead

  • try the Ubuntu server flavour install iso, which IIRC comes without windowing environments

share|improve this answer
    
Actually, I'm trying WVPC as a replacement for VirtualBox, which had some issues with my laptop. Are the ubuntu kernels so different that server does text mode, and desktop cannot? I suppose I can switch kernels using apt-get :-) –  Jon Watte Jan 1 '10 at 1:47

Try adding vga=normal to your kernel command line.

share|improve this answer

I don't have enough "karma" to post comments, but in addition to VirtualBox (which is awesome, BTW), there's also a slew of VMWare products that will do the same for free. VMWare Server and Player both create and run virtual machines, and are pretty reliable.

This link is from 2007, but the short story is no, the graphics are too messed up... and possibly by design.

<conspiracy theory>After all, why would MS want you to run anything linux related using their software?</conspiracy theory>

share|improve this answer
    
Agreed, MS VPC is a gross incarnation, even the BIOS file has invalid values (via a hex editor), and spawns bugs in Knoppix as well. For VMWare Player use easyvmx.com to create machines. –  invert Jan 7 '10 at 8:55

This fixed it for me (under Vista but I assume it will work for Win7):

edit /etc/modprobe.d/blacklist

add the line”blacklist s3fb”

save

reboot

share|improve this answer
    
This actually worked. Details: Windows Virtual PC 2007 SP1; running on Windows XP SP3; running Ubuntu Desktop 9.10 32bit; before applying this hack the console looked like the screenshot above. After applying this hack the console looks like i42.tinypic.com/2yzeigw.png –  Salman A Apr 3 '10 at 6:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.