Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 7 will not connect to a WiFi network using a USB Network Adapter.

I have 3 adapters: a Senoa SUB 364 (EXT), a Repeatit SU2410 USB V2 and a ZYXEL G202. All of these devices install okay on Windows 7 Home Premium on my destop PC (64-bit) and on my Asus Wii Netbook (32-bit).

In each case the adapter can be enabled/disabled and the driver properties says it is working correctly. When I try and connect to a network Windows 7 behaves as though the adapter does not exist and reports no networks.

The Wii has an integrated adapter which works perfectly under Windows and connects to either of the 3 networks available to me.

I have done all the checks I can on the configuration. What seems odd to me is that it happens to all 3 devices on 2 different Windows 7 PCs both of which are working perfectly in any other respect.

This suggests the common denominator is me and I must be doing something wrong. What's also strange is that I cannot find any similar problems being reported on any of the forums.

From what reading I've been able to do it seems like the new WiFi virtualisation thingy in Windows 7 is not recognising the adapters which suggests I'm missing a configuration option somewhere.

Looking forward to finding out if I'm not alone or just being stupid.

share|improve this question
add comment

1 Answer

I've exactly the same problem. Tried three USB network adapters: Netgear WN111v2, D-Link DWA-140, and the Belkin USB 4000 series without success.

share|improve this answer
    
I solved my problem eventually. Not one simple solution but all described in: forums.techguy.org/networking/… Pete Roberts –  Pete Roberts Jan 9 '10 at 15:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.