Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I sometimes find it useful to connect my iPhone to my Macbook Pro by creating an ad-hoc wireless network from the MBP and connecting to that from the iPhone. However, what I find is that sometimes this works and sometimes it doesn't.

When it's not working the symptoms are usually that I see the ad-hoc SSID in the list of available networks on the iPhone, can connect to it from there (including entering my WEP key), and it shows up as the wifi network in use. However I don't get the wifi symbol in the taskbar (it remains as 3G) and attempting to use the connection (e.g. trying to connect to iTunes or Keynote using their respective Remote apps) fails saying that there is so wifi connection.

I've tried rebooting both the iPhone and the MBP, recreating networks with different SSIDs and tried different channels - all to no avail!

I'm especially puzzled that (a) sometimes it works just fine first time and (b) the Settings app seems to think its all connected fine.

Is there anything else I should be trying?

share|improve this question
add comment

3 Answers

I had similar issues and found that omitting WEP encryption, while not 100% reliable, improved it a lot.

Due to the ad-hoc nature of the network and the fact that I rarely used it in public areas, the lack of security wasn't a concern for me.

FYI: I also found that the range was quite limited.

share|improve this answer
    
Thanks Chris. I also heard elsewhere that using WEP make it more stable. In any case I've been trying it either way with no difference. As for the range I have it a few inches away! –  Phil Nash Jan 1 '10 at 17:44
add comment

Might be IP Address problem. Have you checked you iphone's IP when it is connected to you MBP ad-hoc network ? have you tried using a static IP (by default this could be something like 10.0.2.x)

share|improve this answer
add comment

Reset the wireless settings on the iPhone via Settings > General > Reset > Reset Network Settings. Sometimes this helps. Certainly did when the first iPad came out and things were buggy as hell!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.