Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Adaptec AHA-2940UW SCSI adapter, to which I connected a single Atlas 10K III drive (and nothing more). When my computer loads up, the pre-OS Adaptec screen shows (I believe this is called the POST screen), where I can see the Atlas drive listed many times (i.e. with ID0, ID1, ... ID5, ID7, ID8,...,ID15 [ID6 is the adapter itself])

Using the same HD on an Adaptec AHA-2940UB the disk only shows once

Since my OS hasn't been installed yet, I'm not sure if this is a problem (I would guess it is), and if so - how to solve it.

Termination and multiple LUNs come mind, but the cable provides termination and I don't see why a hard drive would request multiple LUNs, especially considering it is not jumpered at all, and multuple LUN support is disabled in the Adaptec controller BIOS (via the SCSISelect utility)

Thank you

share|improve this question
add comment

1 Answer

I think I have found the problem. I changed the controller ID to 7 (from 6) and the HD only shows once now. However, it gets an ID of 6 for some reason (I was under the impression the default was 0, again it is unjumpered). I wouldn't mind it, but the windows 7 setup wouldn't load (hangs on the "Starting Windows" screen) and I suspect it has something to do with the ID not being 0 (it is purely a guess though)

EDIT - OK, it seems the factory default for the Maxtor Atlas is indeed ID 6 so my problems with the win7 setup must reside elsewhere, possibly with the card itself (setup doesn't hange with the AHA-2940U2B)

share|improve this answer
    
Sounds strange to me, too. All the SCSI drive's I've owned default to 0 unjumpered. Is the drive the same ID on the 2940U2B as it is on the 2940UW? –  hyperslug Jul 5 '10 at 12:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.