Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I installed Ubuntu Netbook Remix 9.10 onto my Asus EeePC 1008HA netbook.

It worked perfectly and was pretty quick. Restarting, suspending and hibernating worked just fine but the very first time I shut it down, I can no longer boot back into Ubuntu.

I created 3 partitions. / /home swap

All using the default filesystem (I'm still new but, I believe, it was EXT4?).

Anyway, now I only get this error stating "Gave up waiting for root device" when I attempt to boot.

I've tried typing in "exit" at the initramfs prompt as suggestions but it never works.

So I booted off of the USB stick I used to install and I took a look at my partitions. My boot partition now says "unknown" instead of the filesystem I used. So I used fsck on it which seemed to do something (it asked about future dates which it fixed). Then I attempted to use e2fsck but I always get the error "Invalid non-numeric argument to -P ("/dev/sda1")".

What can I do to attempt to resolve this? It's such a shame because everything worked perfectly and I had no problems with multiple restarts, hibernates and suspends but the first time I shut it down this starts happening. I didn't even hold the power button.

share|improve this question

migrated from stackoverflow.com Jan 1 '10 at 20:29

This question came from our site for professional and enthusiast programmers.

3 Answers 3

If you ran fsck that would have called e2fsck for you.

it sounds like something might have hosed the filesystem UUID which makes the initrd unable to locate your root partition.

try hitting e in grub and changing the root=UUID=..... to just root=/dev/sda1

if that works you just need to set the UUID back to what your system expects..

tune2fs /dev/sda1 -U xxxxxxxxxx

you can see what the UUID was previously by looking in /etc/fstab or /boot/grub/menu.lst

share|improve this answer

Try this, Zee's 6 step Ubuntu fix! http://zeeis.me/ubuntu-boot-error-si...r-root-device/

(This is not my contribution so as the site says please mention a linkback as credit If you wish to share it with anyone or post it on your website)

share|improve this answer

I was able to boot by changing the root=UUID=... to root=/dev/sda1. after looking at /etc/fstab the UUID is the same as the one displayed on the shell when the system failed to boot

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.