Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to help a friend who moved her apps, etc. from an older Windows XP Pro computer to a brand new Windows 7 Home Premium PC. This was done via the ethernet ports through a router. After the transfer completed and the Windows 7 PC rebooted, the network card no longer works.

I tried the Windows 7 network troubleshooter - it agrees there is a problem, but has no clue what it is. Tells me it is a driver issue, but it is the driver from the factory that was working. Copied the driver files from a brand new identical PC just in case, no change.

I tried to delete the card and reboot, it found the adapter and initialized it, but no network.

Tried the netsh winsock reset - no luck.

Tried ipconfig release / renew - no luck

I am out of ideas. Does anyone know how to completely remove the Windows 7 networking crap under the hood so that it can re-build it from scratch? If not I am going to have to nuke the new PC back to the factory config and try it again.

TIA

share|improve this question

4 Answers 4

up vote 0 down vote accepted

Ensure you also uninstall any non-Windows network adapter helper applications (as well as the driver itself), before reinstalling the driver.

Perhaps one of the apps that was moved via PC Mover happens to be an "Internet Security" package or a firewall?

share|improve this answer
    
Bingo - I thought I had removed them, but it must have failed. Zone Alarm, Spy Sweeper and AVG anti virus. –  Kevin K Jan 3 '10 at 21:28
    
Glad it helped - I've been stung by that. ;) –  Ƭᴇcʜιᴇ007 Jan 7 '10 at 6:20

Do you have DHCP enabled and if not, have you manually set the correct IP address?

Next, try downloading the latest version of the driver direct from the manufacturers website and manually install it. Go to Device Management and do update driver then locate and install that driver.

Generally most of Windows built in drivers work, but some are bad and cause problems... As well as this, I have seen that Windows update sometimes contains older versions of drivers, so it is possible that an incorrect driver got installed.

share|improve this answer
    
DHCP is enabled, no luck. Tried the drivers from HP, they have a bug in the installer - it dies on a missing variable in their script. I have an open case there, probably be waiting for ever for that. Get the driver from another brand new identical PC and it did not help. –  Kevin K Jan 1 '10 at 20:55
1  
Look who makes your network card and get them directly from there - e.g. Intel, Realtek, Via etc. –  William Hilsum Jan 1 '10 at 21:50
    
Why my network card and an incorrect windows update I had to remove the new .inf file (from c:\windows\inf) before removing the card and resintall it with the default w7 drivers (the manufacturer driver had the same problem as the windows update one...) (early adopting of w7...) –  fluxtendu Jan 2 '10 at 2:14

Some ideas you might have already tried:

  1. Re-verifying the connection parameters. Please include them in the post.
  2. Turn off IPv6.
  3. Turn of all firewalls and anti-virus (especially the firewall of Win7).

You can also boot in Safe mode with Networking to see if the network card now works.
If it does, you have to track down the blocking application.
If it doesn't, then the network driver is nuked. Try to find a driver on the manufacturer's site, rather than with Windows Update.

Question: What do you mean that it doesn't work? Can it ping the router? What make & model?

share|improve this answer
    
I mean that inside of the device manager there are no ! showing problems, but ipconfig shows no details for the config - trying ipconfig /renew gives errors about the state of all devices, and yet I can not find any errors anywhere. Can not ping without the IP stack getting started. I will try some of these other things you suggested tomorrow when I get back there. Very frustrating. –  Kevin K Jan 1 '10 at 23:43
    
See also the Event Log. –  harrymc Jan 2 '10 at 7:32

Try System Restore (Windows Key > search on System Restore).

This is reversible if it doesn't work and takes a little effort to try. It fixes a lot of problems like this. (Yes, it would be better to understand the problem but that can take you down a very deep rat hole.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.