Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have noticed a bug in the Windows Vista taskbar clock (not the gadget one, the regular good old taskbar time). Sometimes, not that often, the clock display freezes and sticks to e.g. "7.41". And eventhough the gadget clock works, showing the proper time, the task bar clock does not update and shows "7.41"

I am not sure whether this vista specific, but I have only noticed it a couple of times on my home pc, running vista. Anyone else aware of this, and possibly a solution?

share|improve this question
    
Only the clock freezes or the whole notification area ("systray")? –  splattne Jul 20 '09 at 7:56
    
I am not sure about that, now that you mention it. I have noticed it for the clock, but am not sure for the other icons etc. –  Nikos Steiakakis Jul 20 '09 at 8:25
add comment

5 Answers 5

up vote 6 down vote accepted

I have had this, it is a bug.

Are you using the RTM? I am using 7048, if you are using the RTM, I am surprised it hasn't been spotted.

Anyway, if you just click and hold down anywhere on the taskbar and then drag it to any other dockable edge of your screen(s), but don't let go, then put it back to where it was, it will "redraw" the taskbar and the clock will be back to normal.

I have had this issue about 5ish times in around 6 months, and as for other people here, it is not caused by other software as I first had this straight after installing Windows 7.

share|improve this answer
1  
I've had this problem in Windows Vista Enterprise Edition, service pack 1. –  Nikos Steiakakis Aug 31 '09 at 10:56
    
Did doing what I said fix it for you? –  William Hilsum Aug 31 '09 at 14:30
    
I have seen this problem with Vista as well several times. Not frequent, but when it hits you, it can be annoying if you are used to rely upon the systray clock. –  Suma Sep 10 '09 at 10:26
    
Basically this was the fix for me. Time stuck in the tray on Windows Vista. I unlocked the Taskbar, and just did a simple resize, once resized, it updated normally. –  artlung Sep 16 '10 at 16:29
add comment

I've been having this problem for years on several computers. Yeah, it's really annoying. Maybe it's caused by some 3rd party app that developers use? If enough people respond maybe we can find the common app. Besides Microsoft or common software, I'm running:

  • Dropbox
  • Perforce
  • Photoshop
  • Puretext
  • Tortoise SVN
  • Cisco VPN
  • Ultra-Edit

Anyone else have common apps here?

share|improve this answer
    
The only common apps we have are Photoshop and Tortoise SVN, but I do not think anyone of those is causing the problem. –  Nikos Steiakakis Sep 18 '09 at 8:09
add comment

See also Windows Vista bug – clock is not updating blog post

share|improve this answer
    
It mentions the exact same problem, however it does not provide a solution for it. –  Nikos Steiakakis Sep 11 '09 at 11:51
    
I am afraid there is no solution other then MS noticing the issue and fixing it. I have provided the link here for completeness only. –  Suma Sep 14 '09 at 10:21
add comment

This behavior is often caused by third-party software running in the background like the antivirus software.

Try to isolate the problem disabling programs which are running as background processes and are not native Windows programs. If you disable the antivirus software make sure you don't expose your PC to risks.

share|improve this answer
1  
This is probably true, but the problem is that the problem does not occur that often for me to be able to test it. I had this problem come up twice in the last six months or so, thus making it difficult to test all the third party apps. But I will try that nonetheless –  Nikos Steiakakis Jul 20 '09 at 8:23
add comment

I have not seen this specific issue but as splattne said it's likely caused by 3rd party software. One relativley easy way to troubleshoot this is to use Autoruns from Sysinternals/Microsoft.

Launch it and hit Esc to stop scanning. Go to options and mark hide signed Microsoft entries. Go to options again and mark verify code signatures. Hit F5 to refresh the list. Once it's done go to the Explorer tab and unmark everything listed. Reboot. Now you won't have any 3rd party tools loaded into the Explorer process so you might be missing a context menu option or two but this will likely solve your issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.