Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Problem: How do I "lock in" the volume I set through alsamixer?

I'm running Ubuntu 9.10. I adjusted the bass/treble columns in alsamixer but changing the system volume resets them all back to 100%

I did save the settings by running alsactl store but everything is reset once I touch Ubuntu's volume icon in the top menu bar.

This is rather painful because the computer is hooked up to a 650watt system with a massive subwoofer. As much as I enjoy my music, there's no need to have the walls vibrate :)

What can I do to prevent Ubuntu from overriding the settings?

share|improve this question
add comment

3 Answers

I found that using the following works great:

amixer -c 0 -- sset Surround playback -20dB
share|improve this answer
add comment

I believe PulseAudio is the current default audio management system for GNOME. ALSA is a lower-level kernel sound subsystem; PulseAudio is more of a userspace thing.

So you either need to:

  • configure your settings in PulseAudio, using Ubuntu's supplied GNOME audio tools or PulseAudio's own commandline utilities, but not in alsactl, or

  • remove/disable PulseAudio and use ALSA-centric controls.

See this HowTo at UbuntuForums and the PulseAudio FAQ for more. Other links suggest the pavucontrol GUI tool, which is in the repositories but may not be installed by default.

share|improve this answer
    
Unfortunately I wasn't able to modify the subwoofer volume levels through PulseAudio. It seems it only lets one modify the volume for left and right channels, not accounting for other speakers or the bass/trebble levels. –  Hayek Jan 3 '10 at 2:35
    
via the GUI mixer? see the channel_map info at pulseaudio.org/wiki/Modules and other PulseAudio docs; i think you can modify the levels, but you may need to do it via commandline or config file. seems you can also use the alsa mixer if you tell it to use Pulse as the default audio device -- see "ALSA Applications" under pulseaudio.org/wiki/PerfectSetup –  quack quixote Jan 3 '10 at 5:52
add comment

This is an annoying bug that's cropped up in recent versions of Ubuntu, I'm afraid. The only way I've been able to get around it is to manually reset the volume of the affected channel via a command I added to .bashrc:

amixer -q set [Headphone|Master|whatever_channel] [0-100]%

It's a crappy solution, but it works until they get their act together.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.