Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently buy WD Mybook Essential HDD 1 TB. I downloaded and install Smartware software in both my desktop (Windows XP) and laptop (Windows 7) but in both case the software is not able to detect the external hard disc. It shows desktop/laptop (Whichever is apt) on left hand side of software but not the hard drive on right side. Why so?

I need to install Smartware software as my friend had gave me which I suppose had deleted the software.

Update: It requires power and so I gave it. It is properly connected with USB. Its ON and shows LED also. It opens in Windows Explorer as well. When clicked it shows the contents inside on the drive too. Any more info needed from my side?

share|improve this question
    
i see some 'views' but i also wish to see some 'replies' –  Romil N Jan 3 '10 at 11:17

2 Answers 2

I can only suggest to retry from start:

  1. Uninstall any versions of Smartware from your system and reboot after disconnecting the device.
  2. Manually go to http://update.microsoft.com and double-check that you have all high-priority and related optional updates installed: more specifically the latest .NET framework.
  3. Reconnect the device and update the firmware (if applicable) and then the software from here
  4. Try running the Smartware backup.

Please note that :

  • An error when updating the firmware may brick the disk.
    I take no responsibility. If you are unsure about this, please consult a professional.
  • There exist better backup programs than Smartware that are free.
share|improve this answer
    
thanks for the comment. I did what you said in step 1 ,3 & 4. Need to check for step 2. I run firmware but it says " Please insert a WD Smartware device to continue; then click ReScan" even if WD HDD is inserted into PC Via USB. Is anything more needed related to firmware? –  Romil N Jan 4 '10 at 17:27
2  
Does the WD disk show in Windows Explorer? If yes, can you click on it and what does it contain? –  harrymc Jan 4 '10 at 17:35

Before you bother troubleshooting the software side, start with the basics (if you haven't already...)

Make sure the MyBook is plugged in to an external power supply. Do you know for sure that it's powered on? I say this because there are 2.5" external drives that don't require power, but your 1TB drive almost certainly does.

If it has power and you're sure it's turning on (LEDs?), check if it shows up in Windows Explorer, as Harry says. If not, are you getting any indication that something is being plugged in to the USB bus? Usually you get an audio cue and a brief indication in the system tray (bottom right corner) that something has been connected.

If it appears powered on but you get no indication that it's been plugged in to the USB port, try a different USB cable.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.