Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Using Ubuntu's USB Startup Disk Creator (USB-creator-gtk), I created a LiveUSB from the Xubuntu 9.10 LiveCD. When booting, it stalls up with the Xubuntu mouse splash screen displayed.

In attempting to troubleshoot, I used Ctrl-Alt-F1 to check out the first virtual terminal. On that screen, I see over and over again the lines:

stdin: I/O error
stdin: error 0
/init: line 1: can't open /dev/sr0: No medium found
share|improve this question

This appears to be caused by a reported bug: https://bugs.launchpad.net/ubuntu/+bug/500822

As has already been pointed out, disabling the floppy drive will suppress the message. A better fix would be for the casper devs to change line 44 of /scripts/casper-helpers from "eval $(fstype < $1)" to "eval $(fstype $1 2>/dev/null)".

share|improve this answer
    
I disabled the floppy controller from BIOS, and it boots up normally. – user39717 Jun 11 '10 at 7:16
up vote 0 down vote accepted

I didn't find the answer elsewhere, so I decided to document my findings on superuser.

If you just wait a really long time, xubuntu will give up trying to access /dev/sr0, and then the live-usb image will boot.

There is probably a trickier way to get the problem to stop happening.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .