Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Windows 7 and I am wondering how to make all items in a folder show up in the detail view by default. How can I accomplish this?

share|improve this question
up vote 5 down vote accepted

This tutorial will show you How to Apply a Specific Folder View to All Folders in Windows 7

share|improve this answer

Using Windows Explorer

  1. Find a folder that has the view that you want or pick a folder that you want to change.
  2. Follow the instructions from To apply the current view setting to other folders:

    1. Open a folder, click the arrow next to the Views button on the toolbar, and choose a view setting.

    2. On the toolbar, click Organize, and then click Folder and search options.

    3. In the Folder Options dialog box, click the View tab, click Apply to Folders, click Yes, and then click OK.

    enter image description here

Using the Registry Editor

  1. Start the Registry Editor regedit.exe.
  2. Go to the key:

    HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell
    
  3. Delete the Bags key.

    enter image description here

    Note: There also seem to be other registry keys that may be related to this issue. Vistax64 lists these keys:

    • HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\BagMRU
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\Bags
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\BagMRU
    • HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\BagMRU
    • HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags

    Please refer to their article to determine how to remove (and re-create) these keys.

Using REG

  1. Run the following command

    REG DELETE "HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags" /f
    
share|improve this answer

I was still getting inconsistent results with the various solutions. This seemed to work best for me:

  1. Open My Documents folder, Select View - Details
  2. Either (A) move Date column to the far left or (B) right click on date column, select "More" and move Date to the very top (Move Up button)
  3. Click on Date to sort by most recent
  4. Select View - Options
  5. Select View tab, Apply to all folders

This will always sort folders for that document type by date since it is the first column and saved as default view.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.