Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My netbook was having huge audio lag and just abnormally slow processing. After doing some searching on the internet, I found out that I needed to uninstall/reinstall the Primary IDE Channel found under the IDE controller section in the Device Manager. I would then set the Transfer Mode to DMA if available and everything would be great. For a period of time, I would see that "Ultra DMA Mode 5" was the current transfer mode, but every so often, it'd revert back to "PIO Mode", which is when it's really laggy.

What can I do to prevent the Primary IDE Channel to revert from Ultra DMA Mode to PIO Mode? Also, my netbook has BSODed a few times when it is in PIO Mode, without any real explanation.

I have a Samsung N120. Specs are as follows: http://www.samsung.com/ca/consumer/office/mobile-computing/netbook/NP-N120-KA01CA/index.idx?pagetype=prd_detail&tab=spec&fullspec=F. Only difference is that I have upgraded to 2.0 GB of DDR2 RAM.

EDIT: For all who are looking for an answer to this problem, click the link in Kythos's answer and look at number 6 (Re-enable DMA using the Registry Editor). This always works for me now. If on reboot, you seem to only have a black screen after XP is loading, just wait... it is still loading and will show signs of life after 2-3 minutes.

share|improve this question

4 Answers 4

up vote 3 down vote accepted

A full explanation of the issue can be read here you can download a jscript at the top of the page that makes reverting out of pio mode easy, but there is some underlying concern for the current status of your hard drive. If the laptop still has warranty I would make use of it as soon as possible. Make sure you backup your data.

share|improve this answer
    
I just got this locked-in-PIO mode problem for an old laptop. There was a sudden (and slightly worrying) run of controller-related errors in the event log, but after that (despite checking the hard disk, including a full surface scan) no further errors - but performance was horrible. After spotting the PIO mode and failing to reset it, I came here. After reading that link, two minutes in regedit and a reboot, my laptop was back to running at full speed. That's not that fast - it's an old Pentium 4 laptop - but it's still many times faster than it was a few minutes ago. –  Steve314 May 30 '11 at 6:58

The most common cause for DMA reverting to PIO is when DMA is disabled in the BIOS.

Another common cause is bad or too long IDE cables:

You need 80-way cables, not the older ones with only 40 wires. With poor cables the device may work, but Windows will probably step down to lower DMA speeds or even to PIO.

There are a couple causes, those being the most common. You can find other causes and solutions in this winhelp article.

share|improve this answer

I had the same issue with a Samsung X20 laptop. For me, the fix from WinHlp.com did not work.

When looking at the BIOS settings, I found that in the IDE settings, the primary master was set to autodetect (and it correctly detected the harddrive as being DMA capable), but the primary slave (which has a CD/DVD drive connected) was disabled. Somehow this prevented Windows from switching to DMA for the IDE adapter.

When setting the primary slave to "CD/DVD", after reboot both IDE channels now work in DMA mode.

share|improve this answer

Easiest way to reset back to Ultra DMA is download DVD burning software "Copy to DVD" When you insert a DVD to copy it notices that it is set to PIO and asks you if you wish the software to reset DMA and hey presto its done no going in to delete things etc. Captain P.S. one of the reason windows resets to PIO is that the DVD being copied has a flaw, crack or scratch.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.