Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got two different USB flash drives which are formatted MS-DOS(FAT-16). When I plug each into my MacBook Pro (running MacOS 10.6 - Snow Leopard), they don't mount. I can see them using Disk Utility. When I run an Ubuntu VM inside of VMWare Fusion, Ubuntu has no trouble mounting these either.

I've tested with the drives plugged directly into the machine and plugged into a usb hub -- both give the same results.

Is there a setting I've inadvertently set which disables automounting? Is there an issue with mounting FAT-16 drives?

share|improve this question
up vote 1 down vote accepted

How large is the drive/partition? FAT16 can go as high as 4GB, but (according to Wikipedia) is "not widely supported". XP supports it, but earlier versions of Windows do not: they use the more conservative 2GB limit. Perhaps Mac OS X is also 2GB. (Not a surprise that Linux might support 4GB.) For more than 2GB, use FAT32.

I happen to have a 128MB stick with FAT16, and it mounted fine with Leopard (don't have Snow handy here).

In Disk Utility, what happens if you manually try to Mount the partition; or is it disabled?

share|improve this answer
Interesting idea. One drive is 1GB, the other is 2GB. Manually mounting is enabled, but it fails and suggests running First Aid. I ran verify and repair but got the same results when I tried to mount. – Doug Harris Jan 4 '10 at 20:05
The previous comment was for the 2GB drive. The 1GB drive mounted after First Aid. – Doug Harris Jan 4 '10 at 20:06
I reformatted the 2GB drive using Disk Utility as "MS-DOS (FAT)" and it mounts fine. It now reports being formatted as FAT-32. – Doug Harris Jan 4 '10 at 20:16

Aditional software like NTFS-3G would help you out. Yes, it is not for FAT based, but it seemed like it worked for me on FAT-16. It just provides better support. And, it's free, so why don't give it a try?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.