Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have my main user account encrypted with file vault.

After deleting some data (like 20 GB) my free space on the hard drive hasn't change (yes I emptied the trash, confirmed that the files are actually gone, etc,etc). I also tried "erasing free space" in the disk utility app.

I logged off, and rebooted and so far that space hasn't been reclaimed.

I'm assuming file vault or disk utility has some method of reclaiming but I can't find it.

Any ideas?

share|improve this question
    
Maybe the following also applies to FileVault: "How to reclaim all/most free space from a sparsebundle on OS X" at serverfault.com/questions/14112/… –  Arjan Jan 8 '10 at 14:57
    
(Don't forget to accept an answer if things worked out for you, or leave a comment if it didn't?) –  Arjan Feb 5 '10 at 12:09
    
I ended up turning off FileVault then turning it back on. I was never able to force it to clean up. However, when I log out I am seeing the "reclaiming disk space" message. I just log out every once in a while. –  cbrulak Feb 23 '10 at 17:00
    
Don't forget to plug in your computer before logout. Otherwise it won't work. –  user69327 Feb 26 '11 at 21:20
add comment

4 Answers

This worked for me:

  1. Log out of your filevault account
  2. Log in as the Administrator (any other user account works, but it is always a good idea to have a separate admin account)
  3. in the Terminal: su - <yourusername> will ask for you password
  4. hdiutil compact *.sparseimage will ask for your filevault (account) password
  5. Success, 33GB freed.
share|improve this answer
1  
For me, the .sparseimage file is in /Users/.[username], rather than my home directory. –  Xiong Chiamiov May 30 '12 at 3:48
add comment

Disclaimer: I've never used FileVault.

This came up on the Apple Discussion Boards about a year and a half ago. From what I understand, the issue is that while there is free space, the data is still spaced out along the whole FileVault image, and needs to be compacted before being able to free up the space.

What you need before you start:
1) Filevaulted user account ( user )
2) Drive Genius application by Prosoft
3) A second admin user ( user2 )
4) Three hours (depending on the Filevault‘s size)

What you need to do:
1) Log in as another admin user
2) Open „Terminal“.
3) Navigate to the user‘s folder:
cd /Users/ user
4) Change filevaulted folder‘s and subfolder‘s permissions:
sudo chown -R user.sparsebundle user2
5) Rename sparsebundle file:
mv user.sparsebundle user.dmg
6) Open user.dmg with Drive Genius.
7) Defrag mounted image.
This will take a while depending on the actual size of the sparseimage.
8) Close application and unmount image via Finder or mark mounted folder and press „cmd + E“.
9) Rename image:
mv user.dmg user.sparsebundle
10)Change permissions:
chmod -R user.sparsebundle user
11)Log out current user ( user2 ).
12)Log in user and log out to compact the Filevault‘s sparseimage.

I'm assuming you can use any utility you have to defrag the drive (e.g. iDefrag) in place of Drive Genius.

share|improve this answer
    
i've followed these steps and it definitely compacts the partition. –  yanokwa Mar 6 '10 at 19:43
add comment

I just had the same problem and for me a simple logout and log back in was sufficient.

share|improve this answer
add comment

Had exactly the same issue ... stopped getting message "FileVault cleaning up free space" and did not have enough space to try the solution of turning off the Filevault and turning it back on.

Solution:

  1. Go to the Terminal Application (you find it under Applications / Utilities / Terminal)

  2. In the terminal window type the following 2 commands:

    sudo rm -R ~/.Trash
    sudo rm -R /.Trashes
    
  3. After you enter the first command, it will ask you for your password

  4. After you type the 2nd command, then you type "exit" to finish the terminal session

  5. Log out and log back in.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.