Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I ran cat /etc/localtime to see the contents of /etc/localtime - however it's a binary file, so my console became like this:

alt text

You may notice the red text in screenshot is "LiveCD"; commands can be executed correctly, but they display in a weird way. I'm in the middle of an installation process, so I'd prefer to avoid rebooting. How can I return my display to normal?

UPDATE: after running make menuconfig to enter a GUI and quitting, it's back to normal.

share|improve this question

migrated from serverfault.com Jan 4 '10 at 22:37

This question came from our site for professional system and network administrators.

1  
The reason "make menuconfig" fixes your screen is that the program run is linked to a terminal handling library (libncurses I think?) and as part of the initialization of the program, it will reset the terminal to a known state. –  hlovdal Jan 4 '10 at 21:19
    
just a note: this problem is not tied with the Gentoo distribution, it happens on every Linux distro. this scenario is typical for non-UTF8 console outputs. –  Mauro Toffanin Jan 5 '10 at 8:54
    
See also: superuser.com/questions/68796/… –  Chris Johnsen Jan 6 '10 at 5:07
add comment

3 Answers

up vote 12 down vote accepted

yeah, you've output (probably) binary to the console, and its faffed up the mapping.

In situations like this, the command you want is reset.

hit return (so you know you have a blank line), type in reset and hit return again. :-D

share|improve this answer
add comment

An alternative to the reset command is to output the ASCII SI (shift in) character, decimal value 15. This can be entered with Ctrl-O, and should work on any (even ancient) unix in case it laks the reset command.

prompt>
prompt>echo ^V^O
share|improve this answer
    
This worked for me whereas reset did not –  sync Dec 12 '12 at 1:57
add comment

Try running the reset command. If hitting return before and after the reset command doesn't work, try control-J.

Also, Alt-F2 to switch to an alternate terminal can bypass the issue temporarily.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.