Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

what i'm talking about is when you type of the location box url on type, i.e. goog and then it will drop down and show you www.google.com and the site name etc.

it was working fine a while ago until i used ccleaner to clean up on the temp files, and afterwards i find that it will sometimes drop down and show some url but it's sometimes incorrect stuff.

so i try reinstalling my firefox using the latest 3.6.x from the mozilla page. but it doesn't work still.

any idea what's wrong? thanks!

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

I'm not entirely certain where Firefox stores its awesomebar data. My recommendation is to use Revo Uninstaller to remove application data AND registry entries. I find Revo to be very thorough.

You may want to backup your bookmarks or saved passwords before doing this. Otherwise, I'm certain this will work. Once done you'll obviously install the latest and greatest Firefox. Good luck!

share|improve this answer
    
hi Eric, yea revo is definitely nice but the newer version is no longer free :P and i thought about doing that but then i'll lose all my password and other cache stuff so i'm putting that as a last resort. –  melaos Jan 5 '10 at 6:03
1  
The professional version is paid for, but there is still a free version. Look for the link on the right on that page. You can use the FEBE extension addons.mozilla.org/en-US/firefox/addon/2109 to selectively back up your profile (passwords, bookmarks...) –  outsideblasts Jan 5 '10 at 6:28
    
Oh yeah +1 for FEBE. Weave is also an option to backup passwords and other stuff. –  Eric Wendelin Jan 5 '10 at 16:07
add comment

This is because you previously visited those sites, so the awesome bar suggests them. CCleaner probably cleaned your history, so you'll have to visit those sites again at least once to have the awesome bar suggest them again.

share|improve this answer
    
hi John, i did, like i visited facebook like 3-4 times on a daily basis and after a few days each time i type face, nothing comes out. so something is definitely not working. and i didn't mingle with the setting at all, so i have no idea where to look. –  melaos Jan 5 '10 at 1:15
    
Ensure it is set to display suggestions. Navigate to about:config in the address bar, click past the warning message, and type browser.urlbar.maxRichResults in the filter. The default value should be 12. –  John T Jan 5 '10 at 1:48
add comment

It might be worth checking that the check box 'Always clear my private data when I close Firefox' is not checked.

This setting is in Tools --> Options --> Privacy, under Private Data.

share|improve this answer
    
hi JT, you this is definitely not turn on because that's the first thing that i see when i went into the option. :) –  melaos Jan 5 '10 at 2:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.