Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running PuTTY on Windows 7/64-bit laptop. I am connecting to an Ubuntu 9.10/64-bit system running OpenSSH_5.1p1 Debian-6ubuntu2. When I am running some command, the output contains unrecognized characters, like this:

mod_helloworld.c:1: error: expected â)â before â*â token
mod_helloworld.c:28: error: expected â)â before â*â token
mod_helloworld.c:33: error: expected â=â, â,â, â;â, âasmâ or â__attribute__â before âAP_MODULE_DECLARE_DATAâ

However, when I run this command from a terminal directly on the Ubuntu system, the output is clear:

mod_helloworld.c:1: error: expected `)` before `*` token
mod_helloworld.c:28: error: expected `)` before `*` token
mod_helloworld.c:33: error: expected `=`, `,`, `;`, `asm` or `__attribute__` before `AP_MODULE_DECLARE_DATA`

So it appears to be the "back-tick" character causing the problem. Any idea how I can correct this via PuTTY settings?

Thanks, -aj

share|improve this question

1 Answer 1

up vote 5 down vote accepted

PuTTY is interpreting the characters being sent by the terminal incorrectly.

You can change the character set under the Window category in the Translation settings. Change the Received data assumed to be in which character set: to the correct character set. UTF-8 worked for me.

alt text

share|improve this answer
    
@heavyd, that worked for me, thanks! –  AJ. Jan 5 '10 at 13:58
    
Thanks, UTF-8 is particularly useful when running some curses apps –  Mike Pennington Dec 13 '12 at 9:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.