Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Dell Studio XPS 13 has a brightness up & down buttons (Fn + up arrow / down arrow), as do most laptops have. It's running Windows 7 64bit and I've installed Windows Live Messenger (build 14 and something) on it.

When I hit Fn + down arrow, to reduce screen brightness, the Messenger window pops up. That's true whether it has been running in background (system tray / minimized) before or not.

Note, to make messenger hide itself to the system tray, I've set it to Vista Compatibility mode. I don't think that has anything to do with it though, since if I shut compatibility mode off, the problem persists.

There's a thread on the matter here, but with no solution.

Thanks,
Asaf


SOLUTION:

Stop Intellitype when using internal keyboard. See detailed howto here.


EDIT: Some new findings on the matter -

If I exit messenger entirely and restart (or simply stop) the service "Windows Live ID Sign-in Assistant" the problem is solved until I run messenger again. It persists even after entirely closing messenger, until I restart the said service.


EDIT2:

  • The above service "Windows Live ID Sign-in Assistant" actual name is wlidsvc.

  • There's no shortcut defined for messenger, nor is there any other hot key in its preferences.


EDIT3:

  • I'm not sure if it's relates, but some of the Fn keys are not working - Fn + F1 doesn't put the machine to sleep, Fn + F3 doesn't show battery status.

EDIT4:

  • Problem probably relates to conflict with IntelliType Pro. See my answer below.
  • Said conflict also causes Undo command when disabling Wireless (Wireless touch button), and other side effects for various keys.
share|improve this question
    
I've had this problem with a Dell Latitude X300 with Windows XP. –  svinto Feb 2 '10 at 19:04
    
@svinto did you manage to solve it? How? –  Asaf R Feb 3 '10 at 5:57
add comment

4 Answers

up vote 2 down vote accepted
+50

There's a utility called AutoHotkey that will show you exactly what keyboard presses are sent at the application level. You can use this utility to see what Windows is seeing when you press that key combination. Its a bit of a hack, but here goes. (This basically installs a global keylogger...)

  1. First, install AutoHotkey (http://www.autohotkey.com/)
  2. Save this to a file and name it "test.ahk" (you have to have a script running that installs the "keyboard hook" to see ALL keypresses.)
    #InstallKeybdHook
  3. Double click the file to run it. It will show up in your system tray as a green square with an H in it.
  4. Double click the green H icon to open the UI for your script.
  5. Click View menu > Key History and script info.
  6. Press your key combination, then press F5 on the AutoHotkey script window.

You will see they key combination most recently pressed at the bottom. You can press a known key a couple of times before you press the key you want to find so its easier to find. Hopefully you'll see something useful.

share|improve this answer
add comment

Finally found out how to disable this WITHOUT closing IntelliType or installing third party tools n XP:

  1. Start > Control Panel > Keyboard
  2. Go to Key Settings tab
  3. In Key Settings List, look for Messenger and select it
  4. Click Configure...
  5. On the Reassign a Key window, select Disable the use of this key under Custom
  6. Click Finish and Apply/OK

Now you can press FN+Up/Down keys to your hearts content with messenger popping up!

share|improve this answer
add comment

Other than the Dell built-in keyboard, I also use the awesome Microsoft Natural Ergonomic 4000 keyboard (actually, the 7000 keyboard mouse set). Microsoft IntelliType Pro - the keyboard software - seems to interfere with some of the built-in keyboard's functionality, namely Fn + F1, Fn +F3 and Fn + Down Arrow.

Looking at this post I tried running MsKey and choosing "Close Intellitype Pro". It seems to solve the problem.

To sum it up - A conflict with Intellitype is (probably) the cause. I don't have a good solution yet other than closing and opening Intellitype only when needed.

share|improve this answer
add comment

Fn+* is, I believe, entirely done by drivers. That is, the actual hotkey should not be interacting with the OS like that - however, if WLM has a hotkey set (Which can be done in a shortcut to it. Any shortcut.), it could, by chance, be the same as what the Fn+Down really fires.

Step one would be to look in any of your WLM shortcuts, and see if any of them have hotkeys active (Shortcut -> properties -> shortcut tab), second step would be to see if the laptop drivers have some sort of control panel. After that, it'd require a bit more thought to figure out.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.