Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Windows 7 x64. I have a file type that I want to associate with Microsoft Access 2003.

I right-click on the file and select Open With->Choose Default program. In the "Open With" dialog, I select the browse button. I choose Program Files (x86)\Microsoft Office\Office11\msaccess.exe and press "Open".

I end up back at the "Open With" dialog, but nothing has changed. Access is not listed as a program to use to open the file with. The original program (Adobe Acrobat) that is associated with this program is still selected.

Any tips on getting this association to work?

share|improve this question
Yes, this is a bizarre bug that has annoyed me for a long time and several versions of Windows. It only happens intermittently so I have not kept track of which executables exhibit/trigger this behavior, thus I have been unable to find any sort of unique commonality between them. – Synetech Jul 16 '12 at 20:20
up vote 3 down vote accepted

If all fails, you can edit the registry manually (backup the the hive/key first):

Each file type (extension) which has an associated application has a Registry key under HKEY_CLASSES_ROOT.

Or use FileAsoc, a Windows File Association Editor

FileAsoc is open source freeware.

Or File Type Doctor, which is part of the Creative Element Power Tools (shareware)

alt text

share|improve this answer
Thanks, I was able to use the File Type Doctor in the Create Elements Power Tools to get the association fixed. – David Robison Jan 5 '10 at 18:32
you're most welcome. – Molly7244 Jan 5 '10 at 18:39
They way to change this via registry is indicated in another answer here – sancho.s Nov 29 '13 at 18:13

The cause is most likely a quirk in the registry that slipped in for some unknown reason.

Make sure the key value in the following location contains the correct path:


Search for the application name and the file extension in the registry to see if other entries are possibly corrupted as well.

share|improve this answer
This was exactly the issue for me.. once I changed the value at that exact location, it worked fine as soon as I tried to browse -> open again – abelito Nov 19 '12 at 15:03
When the key value does not point to the right location of the application, change it as indicated in another answer here – sancho.s Nov 29 '13 at 18:11
This fixed it for me. Problem was I upgraded it from 32-bit to 64-bit, so it was looking in Program Files (x86) instead of Program Files – endolith Mar 26 '15 at 18:40
Fixing the path to the app in this registry key fixed it. It appears when I uninstalled the app, and then reinstalled with a different path, this registry key wasn't updated. It appears to be a Win7 bug that if the entry for the app exists, windows exits the app selection process without modifying the registry entry; even if the path you select does not match the existing value of the registry entry. The prevents users from changing the path to an existing app using the "Open with" GUI. – chetto Jul 10 '15 at 19:27

The registry key shown above was my problem.


Should read:

"C:\Program Files\Microsoft Office\Office14\MSACCESS.EXE" "%1"

for access 2010.

It still had the entry:

"C:\Program Files\Microsoft Office\Office12\MSACCESS.EXE" "%1"  

for office 2007.

The file does not exist in that location so it did not appear in the application selector until I changed the entry.

Once I updated the registry I was ableto select Microsoft Access directly from the list of available applications.

share|improve this answer

It is a very simples problem, actually: it happens because Windows uses associations based solely on the executable name of the program.

Whenever you associate a program with an extension, it will be present on the HK_CR/Applications list and you can't associate another program with a file extension if it has the same executable name. What happens is that you probably moved the software to another location (you can see it happens mostly with portable software versions) and when you try to point to it, windows will see that the name is already registered and instead will try to use the registered path. When it can't find, it silently ignore the error and presents the dialog back with no changes whatsoever.

The solutions are equally simple: just correct or simply delete the entry on HK_CR/Applications/YouApName.exe and try again. It will work.

You're welcome.

share|improve this answer

I had a similar problem with Sublime Text. It wouldn't show up in the Open With dialog no matter what I did. This is how I solved it.

  1. Open regedit or any registry editor.
  2. Navigate to: \HKEY_CURRENT_USER\Software\Classes\Applications\sublime_text.exe\shell\open.
  3. Remove all the subkeys.
  4. Create the subkey command with value "C:\path\to\sublime_text.exe" "%1" (double quotes included!).

Of course, this will work with any program, not only Sublime Text. Just replace sublime_text.exe with your program's executable.

share|improve this answer

I have seen cases where some dialogs don't prompt you for security elevation and do not give you a message that the change could not be made. Try doing it through control panel

Control Panel -> Programs -> Default Programs -> Set Associations

Or just type "file open" into the start menu search and choose "Make a file type always open with a certain program"

share|improve this answer

I recently had a similar problem with all of my media file associations, and it seemed due to an obnoxious media player called DAPlayer. Even under Control Panel/Programs/Default Programs/Set Default Programs, I was unable to change the default program. Apparently, it set the UserChoice keys under HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts for all of its file associations to read-only access, even for administrators. Even after uninstalling the program, all of my associations remained stuck on "Unknown Application".

The simplest way to fix this is to browse to that key in Regedit, right-click it and select Permissions, click the Advanced button, check "Replace all child object permissions", and click OK.

Or if you prefer the command line, you can use a Windows Resource Kit tool called SubInACL:

subinacl /subkeyreg HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts /grant=administrators=f /grant=system=f /grant="%USERNAME%"=f

But be careful with bulk registry operations like this: improper use could render your system inoperable! I take no responsibility for your actions.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.